Sony BDP-S370 BluRay won't read .m4v from WD MyBookLive with Twonky

 Unable to play video files (.m4v) from my Western Digital MyBook Live on my Sony BluRay BDP-S370.

Product Details:

-Sony BluRay BDP-s370
-Western Digital MyBook Live 1TB  (MyBookLive 01.02.03 : MioNet : Twonky 5.1.9)

 My Sony BlueRay BDP-S370 is DNLA certified to play external files.  I was successful playing a number of video files, including .m4v when I had a Western Digital MyBook plugged into the BlueRay via USB.

I then purchased a Western Digital MyBook Live to be able to access files wirelessly.  The MyBook Live has the Twonky Media Manager on it.  The BluRay player finds the MyBook Live just fine and I’m able to play music files and view photo files.  But when I try to play video files, I receive an error message of “There is no playable file”.  A handful of MPEG files have been recognized, but most have not, which add an additional layer of mystery to the situation.  Why would some be recognized while some are not.  Instructions for the Sony BDP-S370 do support mpeg and mp4 (proved by when they worked fine with the USB connected MyBook).

I’m looking for any recommendations or support as to why the files would work with the wired version of the MyBook but not the wireless.  Not sure if the issue is from the BlueRay, the MyBook Live, or Twonky Media Server which sits in the MyBook Live.

Thanks for any support anyone can provide.

Just as a test try changing the file extension to .mp4 and see if it now works.

Already tried that one with no success.  Thx.

My current theory is that the issue lies in the outdated Twonky software installed on the device which WD has no intent on upgrading, even if it means that the product being sold will not perform as advertised.

You have posted this message in three separate threads. You are likely to get your threads locked by the mods by doing this.

Why do you say the twonky software is outdated? Do you know what goes into qualifing/certifiy/testing DLNA software?

How do you know this is an issue with the My Book Live? A quick internet search shows that this player has issues with other NAS devices


Have you tried updating the firmware on the Sony drive? Do you meet their requirements?

from their site:

Streaming personal content requires a home network with an 802.11 access point (802.11n recommended), internet access and content stored on a DLNA compliant PC or server. Firmware update required for DLNA functionality (available July 2010).

Tested against competitive NAS products… Same result - “There is no playable file” message.


Take a look at the specs for this Blu Ray player:

According to that, MPEG4-AAC is not supported through DLNA. Maybe you can look at converting your media to a format they will work with.