Sonos Local Music Library (SMB) no longer works with OS 5

Sorry - I just added a “new topic” about the Sonos access problem as a new topic, not realizing that the topic was already here. I have a Sonos music system (with their latest software) and my Sonos system can longer access the folder I have on my PR4100 that contains the huge amount of all my digital music. Unfortunately, I’m not that technically oriented and have no idea how to use “samba” or SMB or the other technical terms mentioned above. WE NEED WD TO FIX THIS ISSUE, SO IDIOTS LIKE ME CAN CONTINUE TO USE THE POPULAR SONOS SYSTEM IN A SIMPLE WAY LIKE THINGS WERE BACK IN WD OS3!!! BTW, I did call Sonos support, and the person I reached said this is not a Sonos problem and must be an issue with my WD PR4100, so they could not fix things.

Can @SBrown or someone else inside WD please give us some kind of timeframe when we might expect the firmware update he mentioned in his 11/2 post? WD really needs to address this issue ASAP because my expensive Sonos system is totally unusable right now, and I do not have the IT sophistication to make all kinds of temporary custom programming and complex network configuration modifications to get this working again as it has worked so well for a long time before OS5. I suspect also other networked systems that need to access the NAS are similarly adversely affected too.

Well, it looks like that unless I edit samba using SSH I will have to wait for who know how long for a firmware update to get my SONOS music library back. For those of us with minimal tech skills, it would be nice to have a little more detail on how to add the “ntlm auth = yes” line to [global] in smb.conf. As I understand it, it’s risky to muck around with SSH and I don’t want to accidentally brick my device. So exact instructions would be appreciated.

After enabling SSH on My Cloud, I used Terminal in the Mac OS to log in to SSH (it would’ve been nice to include a link to the WD support article on how to do this). I typed ssh sshd@[IP address of My Cloud], answered yes to are you sure and typed SSH password when prompted. After figuring out how to get that far, I typed “vi /etc/samba/smb.conf” and got a listing of smb.conf file, including [global]. Then, how exactly do I add “ntlm auth = yes” to [global]? Having some trouble.

Update: Never mind. I figured out how to add the option. Found a quick tutorial on how to use the vi text editor online (“A Beginner’s Guide to Editing Text Files With Vi”). Very helpful for all those beginners out there.

Check the announcements for the latest update.

Athough I usually do my share of bitching at WD and this new OS5 IS a trainwreck, this one is more for Sonos. SMB1 is ancient and riddled with holes like swiss cheese, it should not be even used anymore. Sonos should update the SMB support in their firmware.

@broadwayduo

Danke, hatte das gleiche Problem und mit dieser Einstellung gelöst. :pray: :clap:

Saw the announcement. However, can @SBrown or someone else from WD PLEASE provide an estimated timeframe for the firmware version that will incorporate the Sonos fix?!?!

The Sonos NTLMv1 fix is in firmware 5.05.111 under Windows Protocol section.
Set NTLMv1 and NTLMv2, then SMB1,SMB2,SMB3

Thank you SO MUCH WD for releasing this latest firmware so reasonably quickly! I am a very “happy camper” again because I now have my Sonos system back working normally. Please stay safe and well everybody!

2 Likes

Hi @SBrown, i have read through this whole thread, I am running 5.07.118 (greater than 5.05.111) where you mentioned for Sonos to access WD OS5 to secure folder with login credentials. I’ve set NTLMv1 and NTMLv2. I then set SMB1, SMB2, SMB3. In sonos, i can browse the folders but when i try to play i get access to //server-name/public/music/ denied.

is everyone using the same sonos media library link or did you have to recreate it? I’ve tried creating a new library with my WD admin account and am getting access denied; however, i can access the WD Share and see files via Chromebook, Windows 10 and android WD OS5 app can see music on the WD server.

Help!

Hi @BrianSD
Did you ever get your Sonos working following the OS5 update? I unfortunately updated mine about 3 weeks ago and have regretted it ever since. I’ve followed the steps outlined, enabled NTLMv1 and SMB1 but still no joy - I get errors when trying to play music from those shares.

The Sonos system connects happily to my old My Book Live so I might have to keep using that.
Many thanks in advance!

Hi there, sorry for the delayed response. At first i completed regretted my decission and knew NOT to follow the upgrade path. I did eventually get everything working and i can say i actually enjoy the new OS better and the mobile app. Its been awhile since i went through this but i want to say the process looked like this:

The new OS made me create a NEW account. I tried to used the same credentials as before.

I changed the NTLM and SMB exactly as stated in the thread from the WD Support guy. attached is my screen shot of how i am configured.

image.png

After this, i want to say i rebooted and upon reboot the Cloud indexing kicked off. It literally took 3-4 days as everyone says. be prepared for this, it is dog-ass slow and is dependent on your files, images etc. i did not attempt to stop or kill hte indexing process.

after indexing was complete, i could see my Music Folder but it would not play - it continually throw an error.

i eventually removed my music Library and recreated the Library link with my new credentials and it worked.

i think the older path URL looked like this: \\server\public\music_share
and the new path formal looks like this: //server/public/music_share

here’s my sonos Library screen shot with server name blacked out:

I hope this helps, Since i’ve been up and running everything has run better including the mobile app for streaming when i’m away from home, hiking or running and the browser interface to the new WD home page is more responsive.

Huh. . . .perhaps the first favorable review of OS/5 :wink:

(BTW: I definitely think OS/5 runs better than OS/3. My issues with OS/5 are two fold: The feature set for the cloud apps is funky; less than what we had before; and I have lingering privacy concerns on how the OS5 system is setup and operates. Final straw for me was the HTTPS redirect using remote DNS lookup. I am waiting to see some feedback on how EdgeRover is implemented before making “irreversible” decisions regarding OS/5 on the one box that has it - - -until then, my primary NAS device is an OS/3 box)

Hi @BrianSD

Many thanks for this - it’s now working!

All of these issues sound familiar to the issues I had with my MyBook Live. It just stopped working and because it had been out for a bit Microsoft was given as the cause. The PR4100 is getting to be an old system that has fallen far behind the newer NAS units just released in 2020. I was going to purchase a PR2100 and decided I wanted more expandability and looked at the PR4100 but now I have written off both. There are much better options now! When will the updated hardware be released?

I have read all this , but as a mac user i don’t see the answer ? i keep getting that 900 error when i try to add the Nas in sonos set up

I’ve naively updated mine to OS5 and now my Xiaomi IP cam cannot connect.

For what it’s worth, I’ve enabled SMB1, and the NTLauth stuff, and it’s no go.

Also, from Windows 10, I cannot connect (tested using Net Use command) using any username other than admin. The newly created account (and a migrated one with new password) refuse to authenticate.

Is it possible to downgrade the firmware?

This worked for me. Thanks for the help!

A few tips for anyone new to this… Before I did the steps listed here, I created a new user, just for music connection. First, log in directly onto the dev* ice interface (in my case, http://10.0.0.120)

  • I chose to make a new user: musicsonos / secretpassword
  • I gave user musicsonos read access to my Music share.

The as described in this base note, connect to Sonos as a Shared Music Library Folder. From the Sonos App, do the following:

Select System > Music Library > Music Library Setup > Add Shared Music Folder

In the Enter Share Info dialog, enter:

  • Path (mine is: \WDMYCLOUDEX4100\Music)
  • User name (I used my new user account: musicsonos)
  • Password (pw for musicsonos: secretpassword < use something more secure)

It will take a few minutes for the connection to complete, and indexing to start.