Sonos Local Music Library (SMB) no longer works with OS 5

After performing the OS 5 upgrade on two PR2100’s the Sonos Local Music Library (which connects via SMB) no longer works, which worked perfectly on OS 3.

I have enabled SMB 1, 2, 3 in WD Admin Dashboard.

Can WD please resolve this issue in OS 5 so it can continue to work with Sonos for Local Music Library.

i got the same issue cant acces the SMB ip adres

And the MEDIASERVER option is also gone

SMB also didn’t work for my cambridge audio bluray player
always said wrong password wrong name

** Sonos and My Cloud OS 5 SMB Connection **

*use your username and password and not the NAS username and password at the prompt

  • SMBv1 is required or else you get a connection error (900)

EX2 Ultra (5.04.115) SMB1, SMB2, SMB3
PR2100 (5.04.115) SMB1, SMB2, SMB3

iOS iPhone 8 Plus
Sonos App 12.1.2

PR2100 Add Steps

  1. Sonos -> System -> Music Library -> Music Library Setup -> Add Shared Music Folder

    PATH: \\Public
    USERNAME: use your username login
    PASSWORD: use your password

  2. Wait while because the music Library Doesn’t show up under “Browse” for a while
    Eventually you should see the “Music Indexing…” under Browse

  3. Music Playback is working :slight_smile:

That doesn’t make any sense, assume you’re talking about using the Public folder share and accessing as Guest ie no authentication, so entering the Sonos username and password is essentially just filling the mandatory fields with false info, which when passed to the NAS is then logging in as Guest/Public user with no authentication?

My Music is within a share which is password protected, so I need to pass over the correct username and password for the share on the NAS otherwise it will get access denied.

I have tried your suggestion of using Sonos username and password, but as my share is password protected on the NAS, ie not Public, it gets access denied.

I have the share setup with authentication and have SMB set to 1, 2, 3. I have entered the correct username and password and still get access denied.

There is clearly an issue with SMB on the new OS 5, as on this forum there are already lots of other users posting about SMB issues that weren’t present prior to OS 5. Sonos worked perfectly, same share, same username and password on OS 3, doesn’t work on OS 5.

Please try adding a share to Sonos which requires authentication to recreate this issue.

@joshobrien Can you contact technical support with your My Cloud system logs?
We want to check /var/log/samba

@SBrown Can I provide them to you or you raise a case that I respond to with the logs

@SBrown I’ve responded to your private message with my email address, have you got this?

My Cloud OS 5 Users,

I’ve been able to duplicate this issue and have escalated to engineering.


I think I am suffering from the same issue (apologies, I’m not technical)
After upgrading my EX2Ultra to OS5, it seems like I had to reconfigure my Sonos Music Library which is usually quite simple but every time, I try, I get an error message on screen
I have retried the process with and without the NAS password and nothing works. I even followed the advice in the link provided in the popup to increase the IRPStackSize in Windows 10 and that does not help either.
One issue I see is that after being forced to (re)install the Twonky app, I clicked configure that takes you to the Twonky server page and selected the option to Enable Sonos Support. Upon saving this change, you have to OK a server restart & that fails every time with this page appearing and the url
Twonky support say that this is for WD to resolve as the app is provided by them.

In the meantime, I am using the Plex app but it does not offer the same search options such as by genre or by folder, which I how I commonly search my music so having this as a long term solution is not the answer.

Did WD not test this properly before releasing the update?

1 Like

dont delete this! it still isn’t fixed.

or is there a software update on the way? cant acces the SMB on a android tablet of phone

@mjansen Your Android Tablet may require a Samba Protocol change to SMBv1.
Have you set your SMB Protocol to SMB1, SMB2, SMB3 on the My Cloud?

Thats it!! Thanks

how do I do this and will it fix the issue i mentioned in this thread?

I think I have got mine to work
in the WD UI, I went to settings>network>windows services and changed SMB protocol to SMB1, 2 ,3
In windows 10, i went to turn windows features on/off and checked what is in the screenshot then rebooted

Opening sonos on the pc, I went to add music library & browsed for the path my music is stored in but left the username and password BLANK.
It is now connected and updating the music library. hopefully, this will now work

@broadwayduo So you enabled SMBv1 on Windows 10.
Is your music library on the My Cloud in the Public Share or Private User Share that require a password?
Also, what does your Network Settings look like on the My Cloud?
Did you enable SMB1, SMB2, SMB3 like the image below?


1 Like

music is in the public shared music folder and the settings look the image below. Not sure if you saw my post above but I have managed to get it working like it used to now :slight_smile:

Hi @SBrown have you have a response from engineering and when they’ll fix for password protected shares?

This issue is combination of samba 4.5.0(9/2016) removing NTLMv1 from default for security reasons, and Sonos only supporting NTLMv1. We will provide fix in a firmware release as soon as possible.
In the meantime, adding the value of ntlm auth = yes to the smb.conf will allow Sonos to authentic to the My Cloud via SMB when SMB1 is also selected in the AdminUI dashboard.

NOTE: The changes will be undone if the Samba Protocol is changed or the My Cloud rebooted…

  1. Ensure SMB1 is configured in the AdminUI as an SMB Protocol.

  2. Enable SSH and Login on the My Cloud

  3. Add this option to the global config of the smb.conf file using SSH

    vi /etc/samba/smb.conf

    ntlm auth = yes

  4. Restart Samba

    smb restart

  5. Verify the setting is still there

    cat /etc/samba/smb.conf |grep ntl
    ntlm auth = yes

  6. Add Music Library from private shares in the Sonos apps


1 Like

Thanks @SBrown added “ntlm auth = yes” to global in smb.config and Sonos was able to connect to private share without issue.