Something wrong with CNID DB in OS X 10.7.1

Hello all,

Every time I navigate to my MBL in OS X, I open any share and I get the following error:

“Something wrong with the volume’s CNID DB, using temporary CNID DB instead. Check server messages for details. Switching to read-only mode.”,

I can’t save anything on the MBL. I’ve tried rebooting the drive and running diagnostics with no suspect results. My time machine backups work just fine even after I get this error, but that’s on a different partition of the drive.

Tried googling, and all I get is responses for other NAS drives and how to “hack” the MBL…not interested nor helpful.

Any suggestions?

Thanks ahead of time!

Same problem here… Share drive & time machine stop to work…

I have a WD Book World (White) and Lion OSX - After update (13.09.2011) I have following error:

Something wrong with the volume’s CNID DB, using temporary CNID DB instead.Check server messages for details!

What is this??? I wait two months for update and then this???

Could be your user defaults:

I ran a full diagnostic on the drive, (took like 7-8 hours), and it p**bleep**ed. So, I was forced to backup my backups onto a USB hard drive, (took another 4-5 hours) and complete a full restore on the hard drive, (took 2 attempts an another 12 hours). It works now, I just cant stand the SLOW data transfer rates when doing an initial backup with time machine. Oh well, I hope to find a NAS one day that’s faster than a carrier pigeon.

What I must do?

I don´t understand it?

Where the **bleep** is AppleVolumes.default ???

Please help me :frowning:

The Applevolumes.default is a un*x file on the device inside /etc/netatalk.  The only way you can modify it (AFAIK) is to login via the shell, then edit it using a command line text editor like VI.  If you’re not familiar with Un*x I’m sure the process is no fun at all.

And the good news is that, even if you can access and change this file according to the aforementioned link, it doesn’t seem to work :frowning:

Western Digital: we need your help.  Please.

Howdy folks, I was having the exact same issue and decided to do some digging around. This is my 3rd WD Mybook and this is the first one I’ve had problems with out of the gate. I decided to enable SSH on the device and go looking around for error logs. If you are not comfortable navigating a Linux system from commandline and editing files via “vi” please stop here. Otherwise you can enable SSH via the normal MyBook GUI by going to http://<MyBook_Name>/UI/ssh… replace <MyBook_Name> with the name or IP of your HardDrive. Once I was there I noticed that the file /etc/hostname was filled with what looks like the output of a malfunctioning script ( exact text was “/shares/awk: cannot open /etc/trustees.conf” ). I removed this incorrect line and replaced it with the following line:

Replace “MyBookName” with the real name of your device. After that I was able to reboot the device and use my shares normally. I will look deeper into what caused this when I have time. Hope this helps.

For some reason when i posted my last entry it mashed the loopback line into one giant hostname…it should look like this          localhost.localdomain          localhost     MyBookName

For a total of 4 feilds seperated by “tabs”. 

I feel like I have completely p***ed away good money on this friggin’ drive. I had to power the drive down to move my office and when I plugged it back in I got the CNID DB error message. I have since reset the drive and now the set up disk does not pick it up at all. I have a lost the bonjour, dashboard, everything and the LED blinks rapidly 20 times stops for a few seconds then starts up again. I am so over this d**n thing. i have had it less than 30 days. 

I am at my wits end!

I tried to do the SSH thing mentioned and I was able to get to the screen to enable SSH but every time I tried to login SSH I can’t. Keeps telling me that it can’t resolve the address but I was just there setting it up. This is [Deleted] frustrating. What Apple software did you use to SSH and then what software did you use to edit the file. I know these are kinda stupid questions but I can’t copy anything to [Deleted] backup now. 

I have exactly the same problem, it is frustrating again dealing with such error with Apple upgrades and the WD Disk. My main concern is that I can not access anything on the WD Drive, seems that the information is there because the usage space is around 200 Gb, however I can not review anything from Finder.

And of course Time Machine is not working.

I’m planning to sell my WD drive, because I’m completly disapointed with this product, any one intrested? =D

Best Regards.

what are you asking?

I upgrade Lion to the 10.7.1. After that I continuously got the error “Something wrong with CNID” and I can not access my information neither from Time Machine nor Finder. I just saw the users created, but after that everything is empty (no more folders).

I already performed a diagnostic check on the WD interface, also a restart the WD, but the problem persist.

I don’t know exactly what else can I do to solve the problem, could you please provide me some guidance to solve the problem.

Thanks in Advance.

I’m having the same CNID DB message error, although I’m using 10.6.  Anybody come up with a solution that doesn’t require Lynux knowledge? 

I just fixed this problem. The solution is:

  1. Login to shell (you need enabled SSH access on MyBook Live);

  2. Turn off netatalk by this command:

    /etc/init.d/netatalk stop

  3. Run this command to delete all apple db-files (it will recreate automatically later):

    find shares -regex ‘.*AppleDB/(.db|__db.)’ -exec rm ‘{}’ ‘;’

  4. Turn on netatalk by this command:

    /etc/init.d/netatalk start


Doesnt help for me.

Unboxed the WD Live - hooked up - connected via Lion 10.7.2 - CNID DB wrong - read only.

…and I thought: plug’n’play - yeah!

No go since 7 hours…

Any news?

Yeah, the firmware released Thursday was supposed to fix it.


Didnt fix it for me…

Did you try upgrading to 10.7.2? I never had 10.7.1 and never had this problem either …

If this doesn’t help, try the following.

  1. Boot the Mybook. Do not connect any shares.

  2. Enable SSH on the Mybook using http://mybooklive.local/UI/ssh (after logging in at the Web UI).

  3. On your Mac, open Terminal and type the following:

    ssh root@mybooklive.local “/etc/init.d/netatalk stop ; rm -v /shares//.AppleDB/{.db;db_*} ; /etc/init.d/netatalk start”

This is basically the same line as ai_enabled posted already, but maybe easier to copy & paste.

It’ll ask for your Mybook Live root password. If you have just enabled SSH the default password is “welc0me”. Change that password (using " ssh root@mybooklive.local ‘passwd’ ") or anybody on your local network who knows the SSH password will basically have full access to the drive. Alternatively, disable SSH again after this command using the Web UI.

Copy & paste the output from theses commands here in this forum.

Then reboot the Mybook (should not be necessary if you don’t get any error messages, but just to be safe).

1 Like