Something very strange with refurbished units

Some of you have been following my replacement saga (switch issue). Still waiting to hear from WD on replacing my unit again (3rd time’s the charm?), but I decided to watch a movie on the Hub this morning that was on the internal hard drive. About 2/3 the way through it just stopped and kicked back to the menu. I had just checked the time a few minutes prior, so I had a rough idea where it was when it did it. Restarted the movie and tried to skip using the timecode feature. Entered the number I wanted and hit submit only to go back to the movie without and change. Did it several times until I got fed up and tried to FF. No go. Wouldn’t take any of the transport controls (FF, REW, Skip F, Skip B). **bleep**? So, I punch FF a few times and suddenly a dialog box appears saying :This movie does not support trick mode." Trick mode? WTH is trick mode? Click OK on the green arrow and the box resets itself, but still not able to watch the rest of the movie. Looks like a hard drive problem.

So now my 2nd replacement is completely screwed up. Decide that since the first replacement is sitting here waiting on a UPS call tag, why not hook it up and check it out? After the same BS during setup (won’t accept my network password unless I input it and then reboot the device immediately) and updating the firmware, I copy the same movie I was watching to it and finish viewing. No problem, all the transport controls work and skipping ahead works fine. After it is done I decide to try and watch something on Netflix so I menu over to the Services tab and hit Enter. **bleep**? There are only 11 icons and none of them are Netflix. Blockbuster, Hulu Plus and Pandora are missing, as well, among others. How can this be? I try a hard reset and still there are only 11 services listed.

I’ve written a rather lengthy e-mail to product support and let them know that I do NOT want another refurbished unit. They either send me a retail boxed, brand new unit or figure out a way to refund my money. This is ridiculous. I’ve never had so  much trouble with an electronic device since the '80s.

Stay tuned…

You have a lot more patience than I do, I gave up and sent mine back.  I’ll give it another generation or two before I try it again…or maybe there’ll be a better option.

They’ve elevated my problem to Tier 2 support and I got an e-mail saying they would send me a retail boxed unit as requested. Fingers crossed!

YES!!!  “Me Too”!!!  (thought it was just me …)

  •  I just got the replacement (hitherto referred to as “2nd”) for my 1st unit (continuous re-boot - likely related to HDMI resolution “auto-defect” LOL!) connected & configured and … ONLY the 11 base services!!!   **bleep**!!!  2nd had a slightly older firmware than the current version.  (v2.06.10 vs v2.07.17)

I’ve done everything I can think of … to get ALL the services to load/show up …

I’m going to try the “USB Flash drive Firmware Update” method … I wondering if the on-line and/or auto-update function isn’t  doing a “proper update”.

I guess it’s possible they may have sent you a refurb from the wrong region…

If anyone can help me,  

this is my second hub, and I wanted to manually update, because I have a lot of videos of 36 Mbps, which not reproduced the earlier version # 02.03.24,with that came the beginning.

 but when i put the version # 2.04.13, after reboting this Happen:

help me , please!!

Well having read another thread that you wrote.

You are not updating the Firmware, you are updating the GPL code.

You need to use the Firmware

Thanks for your reply,

  I downloaded the Firmware Ver 2.3.24, is correct?   and I have put the files in the USB, when I start up, again  Warning!

after a couple of minutes, your WDTV is upgraded.  —>

but it has several hours, and no upgraded, always 0%
I’ve done wrong?

Hi is me again:

works, it works, i remove the USB and insert again, and update to the original version, but  I get a new version 4.03.24 ?


I will update or not?     i think no   

thanks to you,  god bless you!!

You think right. The version you used was a special rollback version which has a higher firmware number to fool the unit into accepting the downgrade. Once its downgraded the update will display but you can ignore it.

Just wanted to update for anyone that was following this thread.

After receiving 3 refurbished units that all had their own problems, I demanded that WD send me a new in-the-retail-box unit and not another refurbish. Got it a week ago, set it up and so far everything seems to be working as it should. I would say the quality control on refurbished units is pretty poor and I will never accept one in the future. They each had a different problem and one was so scratched up on the front that I would have rejected it just for that alone.