Someone please help me out

I am using WD My cloud 4TB single bay hard drive. It was attached with my router.
But I failed to access it now. It says check the server name or ip address.


The dashboard UI also looks confusing.
Here it says Health is Ok and I cant see the details of the files info here.

I dont know how can i get the files from my drive.

If you previously mapped the My Cloud to your Mac it is possible the IP address changed which is what the error message appears to indicate. You may have to disconnect/remove the existing My Cloud mapping from the Mac Finder and create a new mapped link.

What is confusing about the My Cloud Dashboard? Can you post a screen shot?

The My Cloud Dashboard is not a file manager. The Dashboard is for configuring the features/options of the My Cloud.

1 Like

How will i find or see the divice name of my WD mY cloud?

Thanks dear in Advance

If you didn’t change the default My Cloud name it should be:
wdmycloud
or
wdmycloud.local

If you want to access the My Cloud by it’s IP address you can access your local network router’s administration page and see what IP address the router has handed out to the My Cloud. See your router’s documentation for more information on how to access it’s administration page.

1 Like

The dash board looks like this

Dear,

I try to map my device with the proper naming.
It is “afp://WDMyCloud._afpovertcp._tcp.local”.
But still the same problem.

Try using SMB and see if the issue persists. From the how to map on a Mac link above.

If possible try using a different web browser (like Firefox or Chrome) and see if the issue with the Dashboard persists.

Also if possible update the firmware on the My Cloud.

I also did that.
smb://WDMycloud and smb://WDMycloud.local…
Still the same problem and can’t access anything.

I also tried in Chrome. But both are same.

But regarding Firmware Update.

It says
Important: Ensure you have multiple copies of your data (another backup) before updating your drive.

So if I update what about the my data and files? It sounds very risky :frowning:

Anyway Thanks Dear Bennor.

That warning is just a standard warning message. Any time one does anything to the firmware there is always a slight risk of possibly corrupting the firmware. Like any hard drive the My Cloud’s internal hard drive can fail which is why WD included the capability to backup the My Cloud (using Safepoint or Backup in the Dashboard) to a USB hard drive attached to the My Cloud’s USB port.

You may also want to try a 40 second reset using the reset button on the back of the My Cloud if you haven’t already and see if that clears the issues.

Dear,

  1. There are some important files in the drive which don’t have any backup.
  2. I did the reset both 4 second and 40 second.

Still the problem.

Can I remove the hard drive from my cloud and use it as read only in a linux operating system and copy my files? Can i do that?

Yes. One can remove the hard drive from the My Cloud enclosure in a pinch. Its how one can “unbrick” the My Cloud. If one has Windows they will need a third party driver to read the Linux partitions on the My Cloud drive.

1 Like