Some interface bugs


#1

Hi.

There is already few firmware versions without corrections of some issues:

  1. Bug with option menu:
    Watch movie (xvid for example and sound in mpeg or something else) press option, on first icon that allow switch audio channels, it show: “No audio channel”

After moving on another icon and back to this - now it show correct info.
It looks like info for this menu doesn’t update at menu call, only after moving in this menu.
Same bug appear incase of zoom icon, when watching some lots of movies one by one (after pressing play on first). On first movie choose zoom 0.9, when player goes to second movies, press option and you will see zoom 0.9, but actualy zoom will be 1x. Movings to another icon and back allow it show correct info.

  1. Bug with “Now Playing”

Go to: tunein plugin, start playing some radio.
On screen you can see info about station, picture, some description and genre and some progress bar.
Now press Home button on remote, than go: Music - Now Playing, it show us only picture and station name.

  1. In case of Russian language there is translation issues:

In audio and video settings, setting of 8 or 12 “bit” was translated as “кусочков” - this is wrong it must be just “бит”

As far as i know it was corrected in wdtv live hub, but still unfixed for wdtv live.

New bug was introduced in youtube plugin, right after login we have access to favourites, my video, my playlists, but first seconds this titles have small disposition in their boxes.

This bugs goes from 1.03.xx and even first releases (bug #3), not very big at all, but annoying.

Is there any sense of writing about this unfixed problems in every new thread about new firmwares?

May be some of the wd guys post there that “yes we know and it will be fixed” or this is useless?


#2

Have you tried to PM one of the WD staff so that the issue is escalated?


#3

Anton wrote:

  1. In case of Russian language there is translation issues:

In audio and video settings, setting of 8 or 12 “bit” was translated as “кусочков” - this is wrong it must be just “бит”

LOL, the German GUI also has this item (and a lot of others) hilariously wrong. Don’t expect any changes soon.


#4

Lawrence

Whom exatly?

So what is the sence of writing about bugs in firmware threads if we still need to write to someone who responsible for adding this to their buglist.

Techflaws

I don’t get it, why that so problem ask community to help translate.

Or just ask professional translator to make it.


#5

Bug #1 has been there for the last 3-4 firmwares, it is really annoying! I haven’t seen WD listing it as a known issue to be fixed unfortunately!


#6

Anton wrote:

I don’t get it, why that so problem ask community to help translate.

There’s no need to ask, I offered my translation almost immediately. However, the only one interested in it was b-radd with his hacked firmware.


#7

What’s peculiar here is that WD has already re-done the translations!   The Hub has them.

From what I can tell hacking the firmware, there’s very few technical differences in the language files between the Lives and the Hub.   

So I can’t understand why they don’t implement what they already have.


#8

We’ll look into it. Thanks for the bug reports.


#9

In case 1.05.04:

Bug 1 not fixed, but now text info have disposition and showed at left side of screen and even out of range.

Bug 2 partially, now in Now playing still doesn’t show some info.

Bug 3 still unfixed.

Bug 4 is fixed.


#10

In addition to Bug 1 same problem in youtube while watching few videos in playlist with pressing play (not enter) on first.

Just press option button and change zoom while first movie to 0.9, when player goes to second movie press option again, you will see that menu still shows that zoom is 0.9, but it is 1x, if you move inside option menu with navigation buttons, it start show normal info.

So this behaviour is the same  like in case of usual video watching.


#11

I have a standard television in the bedroom.   i used the UI to set the video to standard from wide-screen.    watched some videos from my mythtv server (awesome)…however,  if i turn my WD live plus off(then back on again).   i need to enter setup and switch from standard back to wide-screen and bank to standard again in order to view the video in correct aspect ratio…  (the setting still reads standard but the video plays in wide-screen, until i go though these steps)


#12

Yes bug #1 is still not fix (option menu is even worse now with the left alignment / display problem). I don’t really get how it could have gone through. As a software dev I know you cannot always catch all the bugs but the ones that are reported should at leats be fixed in the next release (and these bugs are pretty simple to noticed, no need for multiple operations in some weird case… it is pretty basic, the most simple attempt would have helped them see it without any doubt)


#13

Yeap, bug #1 is very easy to catch and obvius… Don’t know how they manage to pork it, but is annoing.