[Solved] WD Black SN750 disappearing from Windows or BIOS/UEFI after sleep or restart

Yesterday I installed a new Western Digital Black SN750 1 TB NVMe SSD. The first time I turned on the computer, everything behaved as it should; I initialized and allocated the disk in Disk Management, and the benchmarks in CrystalDiskMark were in the expected range.

Upon either waking my computer from sleep, or after a restart (via Start > Restart), the drive is no longer listed by Disk Management (or Explorer, or anything in Windows). If I hop into BIOS/UEFI right after one of those restarts, the disk does not even show up in BIOS/UEFI.

If I shutdown completely (Start > Shut Down), wait a few seconds, and then turn the computer back on, the disk reappears. Everything appears to function normally. Until I put it to sleep or restart, at which point the drive disappears again.

I receive no error messages, but looking through Event Viewer, I notice this entry that appears what seems to be after waking or restart:

"Error: Event 11, stornnvme
The driver detected a controller error on \Device\RaidPort2"

Other Notes:
------------

  1. The SATA Mode in UEFI is set to AHCI, not RAID
  2. The NVMe’s firmware is up-to-date
  3. There are no conflicts with drive letter
  4. I can find no listing anywhere for NVMe drivers from Western Digital
  5. Hibernate is disabled
  6. The drive temperatures are normal

System Hardware:
------------------
New Drive: Western Digital Black SN750 1 TB (Port: M2_1 slot)
Boot Drive (Drive 1): Samsung 850 Evo 500 GB (Port: SATA 1)
Drive 2: Seagate Barracuda HDD 2 TB (Port: SATA 2)
OS: Windows 10 Enterprise Edition
Motherboard: MSI B450 Gaming Pro Carbon AC
CPU: Ryzen 1600X (At stock settings)
RAM: 16 GB Corsair LPX 3200 MHz (at 2933 MHz)

I am posting to provide an update, as I believe the issue has been solved (and don’t want to leave an orphan thread dangling):

What seems to have worked is to update the motherboard’s BIOS to the latest version (and updated the chipset, too, but I don’t think that made the difference). I’d held off updating the BIOS because in the latest version(s) had to downgrade some UEFI functionality due to space limitations (16 GB), to make room for supporting 3XXX Ryzen chips (while I still am on a 1XXX chip).

It’s been working for a week now, so I’m calling this solved.