[Solved] Restore broken SSH service on WD My Cloud gen1

Hi everyone. First of all, sorry for my bad English.

In the process of configuring SSH authorization using keys on my WD My Cloud gen1 (fw v04.05.00-327) I made an error, and now I can’t connect to SSH. When I try to connect via Putty from Desktop I get "Software caused connection abort". All other NAS services work, including web interface, access to resources via SMB, installed in chroot software.

As far as I remember, the last thing I managed to do before disabling the current SSH session (yes, disabling the last session was a major mistake):

  1. changed the value of the AuthorizedKeysFile parameter from %h /in the/etc/ssh/sshd_config file.ssh /authorized_keys to~/.ssh / authorized_keys.

  2. changed the owner of /etc/ssh directory to root:root.

  3. restart the service sshd restart.

The console has issued several warnings about the fact that the host keys are not sufficiently protected by access rights, so they will not be used. After that I disconnected, and I can’t connect via SSH any more.

How is it possible to restore SSH service with less blood now?

Upd. I’ve just reload the current sw from the file in the web gui. Everything is worked now.