[SOLVED] Question about sharing files on My Cloud NAS and ad blockers

Hi! It’s been a while since I’ve posted here. :slight_smile: Today, I put some files on my My Cloud NAS and a link so I could share them with someone. When the recipient clicked the link I sent, they landed at the My Cloud page, the “Loading…” message appeared, and the files I shared never showed up. After some investigation, I found an ad blocker installed in the browser blocked access to the files. After disabling the ad blocker for the My Cloud site, the files I shared appeared immediately.

Does anyone know here if any trackers or related things got introduced into the page mycloud.com page that shows the files located on the NAS. I’ve sent out links like this in the past and they have all worked fine, until today.

Thanks in advance!

Depending on the ad or script blocker one may be able to add a white list entry or exemption to the add-in so it ignores the MyCloud.com website.

also check the add-in settings as some times one may set the add-in to max settings that aggressively blocks everything it can. Or check the block lists (if any) used by the add-in to see if it’s blocking the MyCloud.com website.

As always try troubleshooting with another web browser. Browsers like Chrome may have issues on the MyCloud.com website.

Thanks for the reply! It turned out to be a combination of the ad blocker being used with a Chromium-based browser. The same page loads fine in Firefox, with the same ad blocker extension installed.

So, I’m in contact with the ad blocker support team.