SOLVED on router My Net N900 I can't see attached storage device

I cant see attached storage wd pasport studio to my router My Net N900 !

I have reconected and restarted router many times withou result, please help !!! thx!

At least you are using a WD HDD. I was using a Seagate 1.5TB drive (you can see my topic about it) & support says they only guarantee their own products. So I am out of luck until there is a firmware update or something. This still ticks me off it won’t work. Why should it be any different if you have a Netgear router, a Belkin router, or Linksys? Do you see them making HDD? NO!

On your case, it should be very simple. You plug & it detects. It detected my older drives (why it would do that & not new stuff is beyond me).

One thing you might try is to go to the main page of the dash. Then click set-up storage. After you go through that & if that doesn’t work, then you might need to get a hold of tech support. Mine took 6 days to get a response.

But WD guarantees their stuff to work with these routers, so if yours doesn’t, they must be lying. Personally, they should have stuck with Drives only & not ventured into the world of routers if they can’t get it right.

Luckily I got my N750 for $25 for an employee deal at work. I NEVER would have paid the $100 for it. I would have taken it back as soon as the issue you & I have didn’t work.

But for $25 i’ll keep it in hopes they fix these issues. Would I suggest them at work? No, not until they get things like this sorted out. Right now, people guess on whether their HDD will work or not. Mr or Ms customer, I have no idea if your portable drive will work. Take a chance & if not return the router.

And BTW, don’t expect much help on these forums. They are terrible in my opinion. No one responds & there really isn’t much help. Sad from a company like this. At least WD is aware of it. But this along with 6 days waiting for tech support… I probably won’t buy another WD product again.

My only thought would be this networking stuff is so new, no one knows anything about it, or the issues that plague it.

Thanks for your reply I have done so on dashboard attached drive tried refresh but norhing happens

but I can browse the files trough windows network places but sometimes it freezes or it is wery slow

Screenshot - 12_13_2012 , 12_47_07 PM.jpg

HERE IS THE SOLUTION

  1. backuped ma routers settings to file

  2. downloaded firmware version  My_Net_N900_1.03.11.zip

  3. unpacked My_Net_N900_1.03.11.zip to My_Net_N900_1.03.11.bin

  4. downgraded firmware

  5. loaded saved routers config 

after then my router can see my usb drive WD_PP_III_Studio_II again :smiley: