[SOLVED] No update possible


I’m proud owner of an 3TB MBL (NAS-01) and recently I bought some aditional enclosures 1 MBL + 2 MBLD.
The 2 MBLD I got up n running with 4 Brand new WD 3TB green using debrick guide from nfodiz
The 1 MBL (MAIL) I was able to get online with an old Samsung 250GB HDD, uploading the image file for 1TB MBL and manually adjusting the size of the data partition with parted.

The Firmware of the devices are following:
(NAS-01) 02.43.03-022
(NAS-02-DUO) 02.40.06-048
(NAS-03-DUO) 02.40.06-048
(MAIL) 02.11.09-053

Now to the problem …
with neither of the devices I can perform an update via the UI …
“no update available”

Clearly there should be an update for (MAIL) available! Am I mistaken?

resetting version information
echo ‘01.02.03’ > /etc/version
also not working

downloading new firmware from WD
MBL - Firmware Version 02.43.10 - 048 (6/22/2015)
MBLD - Firmware Version 02.43.10 - 048 (6/22/2015)
… and installing it via update from file causing an error due
to md5 checksum mismatch on all devices.

Is there a way to get the newest updated for MBL and MBLD somehow?
Which are the latest updates for MBL and MBLD any way?

Hope you can help me out here.

Thanks a lot.

Hopefully an experienced User will be able to assist.

First thank you for all the help in this forum.

After confirmation that download:
MBL - Firmware Version 02.43.10 - 048 (6/22/2015)
MBLD - Firmware Version 02.43.10 - 048 (6/22/2015)
have been indeed valid firmware versions for MBL and MBLD I could move on to figure out why the hell the updates are not working on my book army.

What I can tell search for updates clearly not working any more.
So I went on to try it with the downloaded firmware versions after a few factory resets and downloads I finally got NAS-01, NAS-02-DUO and NAS-03-DUO updates to version 02.40.06-048 but with the MAIL I ran out of luck.

So I went another way.

1. on NAS-01: create disk image of 3TB MBL
#: dd if=/dev/sda of=/DataVolume/shares/Public/mybook3tb_nas-01.img bs=1M count=4420
2. on NAS-01: copy image to usb-stick or in my case copy it to the usbstick already mounted on the recovery system.
#: scp /DataVolume/shares/Public/mybook3tb_nas-01.img root@
3. on Recovery: flash disk image to new HDD in my case the
250GB seagate for MAIL
200GB seagate for TORRENT (thinking of aquiring even a fifth book ;-))

#: dd if=/mnt/usb/mbl/mybook3tb_nas-01.img of=/dev/sdb bs=1M
4. on Recovery: unplug the drive and put it to a windows system
(parted and gparted giving error: partition outside disk! and could not find out how to get it fixed via linux)
Under Windows use System->Drive Explorer to view the new HDD, ignore the ridicolous large size info 3TB even for the 200GB drive.
5. on Windows: delete false data partition.
6. on Windows: unplug the drive and put it back into the Recovery System
7. on Recovery:
#: parted /dev/sdb
(parted) mkpart primary 4624M -1M
(parted) quit
#: sync
#: mkfs.ext4 -b 65536 -m 0 /dev/sdb4
8. on Recovery: unplug the drive and put it back into the MBL enclosure.
Connect ethernet-cable and power it on.
after a few minutes the LED should turn green
9. on MBL UI: restore to factory settings
10. on MBL UI: reboot
11. on MBL UI: activate ssh
12. on MBL SSH: ssh in (root welc0me)
mkswap /dev/sda1


After that I got a working MBL even with smaller HDD than 1TB, but this steps should work with any drive size I’ll purcase in the future. :wink: