[Solved] - New MBL has no Twonky5 installed

I bought the WD MBL in October with firmware version 02.42.02-012 installed.

Newer MBL don’t offer the twonky media server anymore with the default setup, and I assume it’s not even installed in this firmware.

Trying the Twonky5MediaServerPatch.deb ends up with “WD MyBook Live Error 31101 invalid firmware package”

From what I read in the MBL wiki and in the twonky forum, I might have to downgrade  to an older version ( which one??) in order to have an actual copy of twonky-5 installed,  then do the upgrade to latest firmware with twonky-5 up and running.

this is confusing stuff… I bought that thing, because I know twonky-5 was a good choice for my music collection, the wd dnla even with the latest firmware is to limited for classical music (no composer index is avaliable, and that would be solved by an installation of twony-5).

So the main questions remain:

  • How do get twonky-5 up and running when it’s not installed / has never run?

  • for example: Can I download + install the latest twonky-5 for powerpc from the twonyk website, and activate that one with my WD MBL licence key?

solved !