[SOLVED] My Cloud Home PCB burned! How to extract data out from HDD?

Hi - I am in the same predicament. I removed the Hard Drive and connect it directly to my PC (Windows 8.1) vis USB. I’ve tried using two software products to retrieve the files, Linux File Systems for Windows by Paragon Software and Recoverit. The Paragon software support said their product will not work (something to do with NAS & RAID). I then tried Recoverit Essential I have an open ticket asking why I’m unable to see files? *If anyone knows how I can copy the files off the WD Hard Disk, please reply. Worth mentioning, before I attempted this, I sent the device to a Data Recovery company (recommended by WD). The good news, ALL the files are recoverable, Bad news $799.00 to complete. OUCH OUCH!
Nothing physically wrong with the hard drive. Appreciate any help

I read somewhere that partition guru would do the job. Maybe you can give it a try:


I found the files location (which is 200+GB folder) but all i can see is A-Z folder with bunch of encrypted files inside. I assume that My Cloud Home encrypted the files, am guessing we might need the software running in the board to retrieve it. I did contacted WD support but they said they can’t decrypt them and only recommend me to their data recovery company. This really ridiculous that they don’t have the solutions to decrypt their own method while 3rd party company able to…

Is this for My Cloud or My Cloud Home? I think they have different way to save the data, but I will try and let you all know results…

Bad news, same folder as i browsed using Ubuntu. WD do not give any good solutions to retrieve my files.

Well, not sure if I can post this link here but here it goes:

Just to be clear, I didnt try any of the methods but I think it would be really important to be able to access MY DATA without being dependent on Western digital, if something goes wrong with the device. It just doesn’t make any sense.

Yes FoZi, this is what I told WD, but they only reply like Bot give the same URL of 3rd party Data Recovery and Free Software which is useless in my case.

I did found the post you shared, but the link already expired. So I stuck at “LAN Only image” which I have no idea what is that about.

I guess I gonna find a used device to replace the controller board to retrieve my data, which it sound really stupid. I backup my files but I can’t retrieve my files, WHAT A JOKE.

GOOD NEWS! I able to sort of “decrypt” my files!
Please check

I tested the script running in Ubuntu USB, managed to retrieve some of my files to my USB drive!
Since I have 200GB+ files to backup, so I have no choice to cancel it first.



That’s good news mate.

Thank you very much for your share :wink:

Managed to copy 180GB+ files, still finding way to search the missing 50GB+ files.
But overall it’s working. Hope this post helps others!

Tried tons of tools, and eventually found UFSExplorer Professional version can perfectly do the job, but quite expensive($600). I finally found a place to get the license at $150, now everything is back…

Saw the script, but I assume it only transforms the files without folders’ hierarchy, right? Which means you need to reorganize where they belong to.

it restore with the folders hierarchy, but you might get some duplicate folder but overall is fine for me at least I got my files back for FREE!
Now building my own cloud with Raspberry Pi. Have lost confident with WD cloud system…


I love you badly! Thanks to your wonderfull script Ive managed to recover all my files and realise also that My CLoud HOme is one of the worst product you can buy. I´ll format the 4TB hard drive to NTFS and leave it plugged via SATA to my desktop PC, I´ll throw out the My Cloud Home board and I´ll start paying a Dropbox subcription (its better than give money to those F**CKERS of WD, and sure does protect your files).

Finally, I want to give you money. But dont know ■■■■ about Bitcoins. Is there any (non crypto, sympler) way to do that? Please tell me!



Looks like you were pretty successful in this. I’m having trouble having the script recognize the database. I have the largest volume mounted but am unsure where to go from here. Would I be able to ask for some help?

EDIT: Never mind, I got it working!

Glad this helped… Hope to safe more ppl out there for SAVING TONS OF MONEY!
Really I cracked my head for 2 weeks to get the solutions…

GREAT! Happy Recovery!

Hello Christpher, Thanks for the script, but Im a “dumb” in LINUX. I have instlaled on parallels and now I can get the files and see them on the folders. Can you tell me the “steps” to make this script usefull? I have to download all the “Data” folder inside the restdsk folder to another disk and run the script?
If you cna send a video or something, will be GREAT.

Sorry, there is no video.
Basically you just need to edit restsdk_public.py,
change the below data:

db=’/restsdk/data/db/index.db’ #where the file DB is stored example: /data/db/index.db
filedir=’/restsdk/data/files’ #where the files are stored example: /restsdk/data/files
dumpdir=’/location/to/dump/files/to’ #where you want the new files dumped example:/EXTERNAL/FILES

then run the python script
i think as long as u have those PATH right, it will copy and recover to “dumpdir”

Thanks. My question, and sorry … how can o run the script ? Wich commands I have to do on terminal on Linux ? (Ubuntu) ? This will make a copy where ? I decide where I want the copy changing the paths ?