Solved: mount.cifs on raspbian buster to MyPassport SMB share


I had brought a WD MyPassport pro to participate in my home wireless network and had turned on its Windows Share feature.
Many of my network clients were able to detect and connect the share on the instant. Even on a raspberryPi, running raspbian Buster, the share “Storage” showed up within the graphical UI file browser (thunar of XFCE desktop suite) and it was operational.

But I faced problems to make the share available as a filesystem mount for commandline.
I tried the mount like this:
mkdir -p /mnt/cifs/portanobile/storage
mount -t cifs //portanobile/storage /mnt/cifs/portanobile/storage -o guest
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

After lots of fiddling with upper/lowercasing and a number of mount options, I was about to give up.
Then I tried the same commands on another linux machine, which is running “pure” debian x86, and
the very same commands succeeded.

So on this machine I had the chance to have the mount command list out the options it employed for success:
mount | grep cifs
//portanobile/storage on /mnt/cifs/portanobile/storage type cifs (rw,relatime,vers=1.0,sec=none,cache=strict,domain=PORTANOBILE,uid=0,noforceuid,gid=0,noforcegid,addr=,unix,posixpaths,serverino,mapposix,acl,rsize=1048576,wsize=65536,echo_interval=60,actimeo=1)

I did not want to copy all of them, so I took a first shot at the “vers” option (because I remembered from the mount.cifs man page, that its default has undergone some changes between kernel versions).

This indeed was the trick that made it possible to mount the share also on the raspberry machine:

mount -t cifs //portanobile/storage /mnt/cifs/portanobile/storage -o guest,vers=1.0