(solved) External hard drive disappears or is not recognized

Here was the process I used to install the external hard drive.

1)  Installed the software and drivers from Western Digital’s CD.

2)  Plugged in drive to USB 3.0 port or 2.0 port. 

  1. My OS is Windows 7 Home Premium 64-bit

  2. My motherboard is GA-Z68X-UD3P-B3

  3. I built this machine myself

Here are my symptoms.

1)  Can write or read to drive, and as long as I am doing so, the drive remains active.

2)  After a period of inactivity, the drive disappears from the device manager (click start, then right click on computer, then click on manage, then click on device manager) and Start -> Computer -> Hard Drives list.  No other software sees the drive. 

3)  If the drive is still plugged in, turned on, and connected and I reboot the computer (no matter if the drive is present in the device manager or not)… after reboot the drive is still not present in the device manager or hard drive list.

4)  I called Western Digital tech support and they thought it could be a cable issue, so they sent a new USB 3.0 cable.  No change in symptoms. 

  1. I am able to use the drive just fine on my linux laptop and my girlfriend’s laptop.  So… leap of induction… the problem is my computer. 

  2. I am plugging my drive straight into my motherboard, not through a PCI card then my motherboard.

  3. Now.  I am able to resurrect the drive and it reappears on the drives list if I unplug the drive, wait 10 seconds, then plug it back in.  But sooner or later it disappears again.

Here is what I did to resolve the problem.  I suspect that the first and last steps are all that is needed, but I post the others because I have read a lot of forums and potential solutions.

  1. Go to Start -> Computer -> Right click on the drive and go to properties -> Click the Hardware tab -> click your external hard drive again then click on properties down below -> Under the General tab click change settings -> Under Policies click better performance to enable write caching.  You will have to do a safe uninstall every time you want to disconnect the drive, but what this option does is constantly writes to and reads from the drive so it never goes inactive.

2)  Went to my motherboard’s web site and downloaded latest drivers and bios settings, especially anything related to USB and intel (which is the northbridge communication on my motherboard).  Installed those, making sure they were 64-bit.

3)  Ensured Windows is patched up completely by doing windows updates.  There is one patch in particular that works if you have 64-bit and greater than 4 GB RAM.  Sorry I forget what it was.

4)  Uninstalled and reinstalled anti-virus software.  In this case it was McAffee. 

5)  Went to video card website and downloaded ALL of the latest drivers.  In my case I have a GTX 580 and there are a number of drivers:  3D vision, regular graphics, Physix,  HD Audio, Nvidia updates and nForce.  Why do this? Because anything that communicates with the northbridge could be suspect.

6)  Downloaded and installed latest drivers for the hard drive.  Key here is the SES driver and the regular Western Digital Driver package (as it shows up in my Unistall programs list).  In my case, I went to  http://support.wdc.com/product/download.asp?groupid=125&lang=en and downloaded/installed the universal firmware updater for windows, and the WD SES driver.

7)  At this point, the new USB 3.0 cable arrived.  My symptoms now are just as curious.  Now the drive stays active 24/7 as long as I plug in the drive after the computer boots up.  But if I leave it on while shutting down it does not appear after boot up.  To fix this problem, read on.

8)  Formatted drive using windows as NTFS, then hardcore formatted it using linux command “dd” and other code.  This to remove any bloatware and malware – just saying, you never know.  If you still have data on the drive you should have seen the drive by now and been able to get it off. 

  1. At this point I suspected that the anti-virus might be the culpret because the computer was taking longer to boot up.  So I turned off active scanning and rebooted.  Did not work.

  2. Next I downloaded Mini-Partition Wizard from cnet.com.  After installing I did a check file system and selected fix any problems.  I also changed the drive letter of the drive to something other than D:.  I also set the drive as logical.  Click apply to make the changes permanent.  You can also change the drive letter in Windows by going to Start -> right click computer -> click manage -> disk management.  Here, also make sure the drive is set to active.

  3. Unistalled WD Smartware.

12) Ok. So I clicked Start -> right click computer -> click manage -> click Services and Applications -> click Services.  Click Name to sort alphabetically by name.  Find any services that start with WD or say western digital.  Double click on them and then click stop.  Then select Startup Type Disable.  Alternatively you could just not install the software that comes with the drive from that CD.  

In summary, I believe the problem is two fold.  First the drive does not power manage itself properly and you have to write or read to/from it constantly to keep it active.  Windows write caching fixes this.  Second, WD’s drivers conflict with Windows’s drivers.  Make sure you are using only Windows drivers.

1 Like

MrFixit_ha, this is most helpful and several Users will be assisted by these instructions you have kindly posted.