[SOLVED] Blank Dashboard and No Login Prompt (Firmware 4.04.00-308)


After upgrading to Firmware Release 4.04.00-308 (9/28/2015), I could not access the dashboard on 4TB MyCloud.

After upgrading, it did reboot and present a screen with checkboxes (participate in product support / license agreement).

_ However, it never prompted for a username/password and the dashboard was inaccessible.  _The dashboard was completely blank, regardless of the number of reboots, browser refreshes, or cycling the power on the device. This was the same regardless of brower (Chrome, Firefox, Internet Explorer, Safari) or operating system (Windows, Linux, IOS).


I’m listing these steps here for informative purposes only so that it may help someone with a similar problem in the future.

To fix the blank dashboard problem related to the "cloudholders’ group, YOU DO NOT NEED TO DO THESE DIAGNOSTIC STEPS. Skip to the “Solution” section below.

  • I still had access via SSH and was able to downgrade the firmware to a version where I could still access the dashboard. (Downgrade instructions appear elsewhere on these forums. It’s a bit of a pain to find an older version of the firmware, but it’s possible.) 


  • With a working dashboard, I was able to do a “System Only Restore” (Settings > Utilities) and reboot. This appears to effectively restore the /etc/passwd and /etc/group to factory default (also resetting the root password to factory default “welc0me”).

NOTE: I’m sure there is a way to do “System Only Restore” from the command line. Had I taken the time to locate that command, I would NOT have needed to downgrade the firmware. I only downgraded the firmware to regain access to the “Settings” functionality of the dashboard.

  • After a reboot, I was able to access the dashboard (under the now downgraded firmware) and apply the latest firmware

  • After rebooting, the dashboard was now accessible under the latest firmware


The latest firmware creates a group “cloudholders” with group ID 2000.

  • If you already have a group with GID=2000, the “cloudholders” group is NOT created during the firmware upgrade!

  • If there is no “cloudholders” group, there is no login prompt and no visible user feedback regarding the problem. (Sounds like a bug to me.)

Additionally, only members of “cloudholders” are listed under the “Users” tab from the dashboard.

  • Since I use my device as a general backup system more than as a media server, I had created numerous additional users and groups. One of the groups I created already had GID=2000. 

  • Only after performing the “System Only Restore” and reapplying the newest firmware was the “cloudholders” group successfully created and dashboard login could occur successfully. 

  • I did not want to change my user/group numbering scheme to accommodate “cloudholders” having a GID=2000.

  • I was able to confirm that there were no system files having GID=2000 on the drive.
    $> find / -path /DataVolume -prune -o -group 2000 -print

    This reveals files having a GROUP ID of 2000, ignoring everything in " /DataVolume"  (where your shares ultimately reside). The “-prune” option in the find command only affects the results returned by the find command. It does NOT alter the content of “/DataVolume” in any way. 


If the following four facts are true, the steps (below) MIGHT work for you

  • you already updated to the latest firmware
  • your dashboard is blank
  • you have SSH access to your cloud device
  • there is no “cloudholders” group

WARNING! Please only do these things if you understand what you are doing. If you are indeed having the problem that is solved by these steps, it is because you are using the device in a not-completely-typical way. Hopefully you already know what you’re doing. These instructions are meant for users who already have a good understanding of basic Unix/Linux system administration and specifically how the WD MyCloud device works. You do this at your own risk!

The “cloudholders” group does not need to have GID=2000. My device works just fine with it at another number.

  • Connect to your device via ssh (either by loging in as root, or elevating your login shell using $> su -l)

  • Confirm there is no “cloudholders” group
    $> cat /etc/group | grep cloudholders

  • Create “cloudholders” group
    $> groupadd -g <SOME_UNUSED_GROUP_NUMBER> cloudholders

      I used “1999”, so my command was $> groupadd -g 1999 cloudholders

  • Add the approprate users to “cloudholders”
    $> usermod -a cloudholders <EXISTING_USERNAME_1>
    $> usermod -a cloudholders <EXISTING_USERNAME_2>

    $> usermod -a cloudholders <EXISTING USER_NAME_N>

  • Reboot the device
    $> reboot

After the front panel light turns blue, use the web browser of your choice to browse to your device. You should be presented with a password prompt.

If it does not appear, try <CTRL>-<F5> or <CTRL>-<R> to force a refresh.

If that does not work, <CTRL>-<F5> or <CTRL>-<R> and press <ESC> while the page is loading. Then <CTRL>-<F5> or <CTRL>-<R>.

Good Luck!

1 Like

Hello and welcome to the WD community.

Thank you so much for sharing this, hopefully this might help some users experiencing this issue with their device.

And what if SSH is disabled after firmware upgrade? :frowning:

40-second reset does a system only restore. See the user manual for details.