[SOLVED] accessing airport extreme base station disk from WD TV Live Streaming

Hi All

So I bought one of these wonderful looking WD TV Live Streaming media players today and am having issues accessing network shares

My current setup is

MacBook Pro

PC with Windows 7 64bit

2x External HDD attached to Apple Airport Extreme Base Station with shares in Media and Media2 

I can access the hard drives wonderfully well through samba by typing smb://AEBSname/Media or smb://AEBS/Media2 through the mac or windows (or \AEBS\Media etc. in windows). But when I attempt to connect with the WD TV Live Streaming I get a “No Media Files Present”. This is partially true as the Media2 Drive has TV Shows and Movies while Media has music.

So how can I access the folders in the shares?

Hope this makes sense and thanks for the help


First things first: Can you see the computers themselves and play their files on the WDTV? I’d stay with the basics before moving to using a USB drive as a NAS via the router…

I agree, sorry to say this but Airport Extreme can be a ***** sometimes. Try to share a folder in you computer and see if you can access the files in this folder.


Firstly thanks for the replys. 

As for being able to access other media on either the PC or the macbook pro (tbh I havent tried the macbook) I managed to access the PC fine which indicated that it was not the WD TV Live that had the issue. 

Next thing I did I played with the settings of the AEBS which led me to do the thing I usually do - Strip security down to start with and then build it back up.

In the end I have enabled the guest access for “read only” to the airport disks and this has solved the problem. I did attempt some passwords on the disk and accessing them using accounts or disk passwords but with each of these options I had no success.

As it is my network is not really in range of being accessible by others outside of my house and therefore the guest account is fine by me.

Hope this helps someone else


Dear Mr Pizza Matrix I would love to give you kudos if you could help me out with the sme problem!!!

I am in the same boat - MacPro running through an Airport Time Capsule base station to my wired network.  My WD-TV live is in my living room, sitting right next to my apple TV on the same network and the Apple TV is able to see my computer just fine.

I have renamed my MacPro “RupertMacPro” but the WD-TV only sees my router name and a computer named “macintosh.”  what’s even weirder is that the connection seems to come and go - I get an error message saying that folder is no longer available?

THanks in advance for any help you might be able ot give!!!