Solution: "No internet connection" when accessing some folders on the mobile app for iphone

So here is what I found after a long time not been able to access all my stuff through the mobile app.

I use a macbook pro and an iphone 5s.

I have a Share on My cloud mirror and inside this share I keep folders like, “music”, “videos”, “photos”. So, using finder, I changed the icon of those folders for better visual identification using finder command+i shortcut and then copying the same icons of the mac Home folders to these folder on the My cloud mirror. What happened is every folder on the NAS that I change the icon, I was not abble to access using the mobile app. It gives the message “no internet connection”.

It took me a lot of time to realize that the change in Icons was the reason I couldn’t access the folders. Yesterday I deleted those custom icons and I could access them normally.

Now, if someone is having the same issue you can try this. Also it would be great if someone from WD could fix that.


Thanks for sharing

Hope this help other users on the community.

I had the same problem. I use MacBook Pro and iPhone 6. Everything worked fine until I made an backup on one of the folders via the cloud service “Copy”. “No Internet Connection” it said. After reading this, I looked up a icon that had been added in the folder. I deleted it, and so the problem was solved.
Thanks so much!