Solution - How to fix freezes and crashes during playback on 2.6.10

Hi all,

The Problem

So i bought the live hub, and immediately updated to 2.6.10 (because it so kindly asked me to), and as a result the box would freeze/crash every few minutes and i had no option but to pull out the power chord and reboot. Once i did that i’d once again get 3 minutes of sheer entertainment before rebooting again.

Someone on the forum suggested disconnecting the LAN cable to be the fix, so i tried that and it worked!! But then again, what use is the box if i can’t connect to the internet on it OR use it as a NAS (which i do). So i decided to fiddle around with my router settings to get the box a cleaner internet connection and make sure no data packets were being missed due to my router (i have a DLink router - don’t know the model number, but that doesn’t matter… all routers will have the options i’m going to speak of below).

The Solution

Here’s what i did ( some of you may feel you’re putting your network at risk, in which case, please do not proceed).

  1. Login to your router as admin

  2. Go to your “PORT FORWARDING” settings and add a new rule to ENABLE BOTH TCP and UDP for Ports 1 to 65535 for the IP Address of your WD TV LIVE HUB. Remember to do PORT FORWARDING and NOT port FILTERING - both of these do the opposite things (while forwarding OPENS certain ports for an IP address, filtering CLOSES those).

  Screen shot 2011-07-23 at 1.22.32 PM.png

  1. That’s all folks, your hub should now work seamlessly.

 Go to your “PORT FORWARDING” settings and add a new rule to ENABLE BOTH TCP and UDP for Ports 1 to 65535 for the IP Address of your WD TV LIVE HUB.

I’m sorry, but this is absolutely TERRIBLE advice.

You’re completely exposing your Hub to the internet, anyone out there could get into your Hub and copy or delete all of your files.

Even D-Links documentation has a strong warning:  “Putting a computer in the DMZ may expose that computer to a variety of security risks. ”

Not only that, but that will also likely break any application running inside your LAN that is establsihing a UPnP rule to get outside-in access.

@ TonyPh12345

Yes, as i mentioned - if you feel you’re putting your Hub at risk, do not do it.

I removed the DMZ comment from above as i was wary of that as well and the HUB works without it being in the DMZ list, however until i can isolate the ports being used, im keeping them open to be able to use the box.

The Hub doesn’t need *ANY* ports to be forwarded from the outside in!

The only exception to this is the WD2Go port that is needed for WD Photos to work, and the Hub will open that port automatically via UPnP.

Could you perhaps shed some light on why this fix made it work then?

I have no idea, but I can tell you that’s not a “Fix”… that’s a nightmare waiting to happen.

What happens if you disable forwarding completely. I am not forwarding anything in my modem (thomson) Still my iPods, Voip-phones and computers can connect to the internet. Only for the WDTV-hub I enabled UPnP. But I don’t forward any ports. I also think you give a badn solution.

You should change some settings in your modem. Try to go back to factory settings and try again from there.

No IP fuzz, no mac-address fuzz no nothing.

Keep the music simple I would say.

Don’t need no keyboard player running al of them ivories.

With them never ending solo’s, you have to keep it at ease.

Go to this site and maybe you can find out what to do:

http://www.smallnetbuilder.com/lanwan/lanwan-howto

Hi !!

Any better solution for this ? ??

I have this problem also with 2.07.17 !! without internet cable everyting ok, but with internet just freezes. I can not access my files !