Solid Yellow

Have a blinking green light - when ethernet is connected to computer
Solid yellow on the front (not blinking) for the power
Triied the reset 40 seconds while power is off…
Reconnected … solid green on the back for a second then nothing - solid yellow on yhe front

Im am not techy
Prob shud have used google cloud instead of a “device” but now what do i do? Hundreds of dollars invested and this device is broken? After a few years?

Help

Have you changed internet providers or routers recently? Are you using AT&T or one of the routers mentioned in the following WD Knowledgebase article?

What happens if you connect the My Cloud direct to a computer? Have you tried connecting the My Cloud to a different network port on the router? What about changing the network cable? Can you reach the My Cloud Dashboard? Is the router handing out an IP address to the My Cloud (see the router’s administration page)? What other troubleshooting steps have you tried?

Tried reset 40 seconds. … tried changing all ethernet cables. Tried connecting to computer vs router. Tried old router (as i changed to a new lynksys router a few monyhs ago)
Im in canada so on cable internet but that has not changed
All other devices
Tried a different power adaptor 12v and yellow light turns red after 5 mins
When i replug in the original ac adaptor the light goes back to yellow
Soft noise (as always) like the unit is running. I have no access to the dashboard - computer reads ‘error message’ cannot connect to device. Should i try and replace the power cord?

You may want to contact WD support directly to see what they suggest.

What you didn’t try was to connect the My cloud directly to the computer with out going thru the router.

Yep tried that. Its doesnt seem to like the power cord/connection.

Why do you think the adapter is bad?

Not sure. Just a yellow light. Used to be blue. When i try to access from my phone - error (904) what does that mean?

Have you tried to go into the router to see what devices are connected to the router?

What firmware are you running?

Solid yellow is an old error indicator, saying no network connection.

So it’s either a faulty network port on your MyCloud , or a fault with what is connected to it. Since you say you’ve tried a different cable and router, that does point to the network port being faulty.

Have you looked at this?

Is there any solution if the network port is faulty?