Solid red light, will NOT reset

I was getting a solid red light on the front of the My Cloud 4T storage. I removed the drive and am trying to recover my files but am getting “drive is not initialized” message. How can I safely initialize without loosing my data? I have very important files on this drive!

Initialization, by definition, will erase your data.

Chances are you’re not finding the data partition since it’s EXT4 format which is not native to Windows.

There’s several guides here on the community that tell will tell you how to recover your data using Windows.

@camntx I see that you have been on WD Community since 2014. Is this a first generation My Cloud? What troubleshooting steps did you take before removing the drive? What did you find that led you to believe it must be removed? Below is information from the User Manual as to what may cause a Red LED on the front.


You will need an extfs driver. See this thread:

I did the 4 sec reset and 40 sec reset several times; I have tried three different data cables and switched from my router to my modem direct. I get nothing but red light! I finally took it out of the case and have it in a docking station. Downloaded ext2fsd installed it and am still not able to retrieve my data! Ouch!

A quick look ext2fsd suggests it cannot support ext4 file systems, which is what the user data partition is. Try the Paragon software product in the link I posted.

I made a new post where i described what my problem was.
It was just a faulty connection (black coated) between the hdd and the logic board that is screwed on.

Dissasembled and cleaned now its working.

I had exactly the same issue you described. After disconnecting from power it started with constant red light. Nothing helped and at last the hdd was not recognized from my pc anymore.

It seemed that the cloud died slowly because of bad connection between the hdd itself and the direct attached
logic board

I have apparently totally screwed EVERYTHING up! ext2 never recognized it, and paragon can’t find it. When I look in the admin tools, it shows as “RAW” with -0- data!

Exactly the same issue …disk not recognized or just as 0GB.

The connection on the board was slightly black coated. After cleaning it went back on

What tool did you use to release the board on the drive. I don’t have anything that will fit!

Old credit cards. Insert about 1cm.

[edit: apologies; I misunderstood the question to be about opening the case]

You just have to pull after the torx screws are away. It’s a bit glued with the white termal pad
on the chip …the white stuff on the picture

I guess I wasn’t clear. I don’t know what tool to use to take the (torx) screws out.

A Torx driver…

well, I finally got my torx tool & was able to remove the board. There was no dirt, but I took a lintless rag and gently wiped it and reassembled the drive. Still getting solid red light! I guess I have a fried drive! now I have to try to retrieve my files! if anyone has a clue, it would be greatly appreciated!

Use the forum search feature, magnifying glass icon upper right. Lots of past discussions on how to try and recover files/data from a My Cloud hard drive. One can remove the My Cloud hard drive from it’s enclosure and attach it to a computer using a USB to SATA dock/enclosure/cable. Because the My Cloud hard drive uses Linux, if one is using Windows they will need to use a third party program that will read the My Cloud/Linux hard drive contents. The following link which was posted earlier in the current thread is relevant.