Solid Red Light mybooklive 3TB


 I was doing a backup job on my WD mybooklive 3TB and it went offline with a solid red light status. I tried to reboot, soft reset the MBL with no luck with that and it is no longer showing on the network even if I scan the whole network. I tried to get the 3TB hard drive out of the case and connect it directly to the computer or by USB with no luck since it is not detected on Windows disk management or linux rescue CD gparted. I used more than 10 softwares but non of them can see the hard drive.   Now once I connect the HD on the network I can hear a the sound of it and 2 clicks and then I feel like it keeps rebooting and doing the same 2 clicks.   I am not sure what else I can do to recover the data since it is so important to me.  



Sorry to hear that.

Normally, a red light on the drive means that one of the following faults was triggered on the drive:

  • Disk SMART failure
  • Data Volume does not exist
  • System Volume does not exist
  • System thermal shutdown (75C)
  • Unsupported drive detected

See if the following link helps

I tried that as well. I cannot unbrick since gparted cannot find my HD. I also cannot SSH when the MBL is connected to the network.

From Debrick guide V1, you tried the following?

“If DiskInternals Linux Reader will not recognize the partitions, it may be because you have a corrupt partition table.
Try using R-Linux

if you cannot see the drive with gparted or other app which allows to see Linux partitions on Win, the drive is probably dead.


Also, are you sure USB-SATA adapter is good?

And last, you could try some Linux forums for help, these devices have Debian Lenny version.

Yes, I tried R-linux, linux reader… other apps from hiren’s but with no luck.

When I connect the HD using the USB-Sata I can see the “USB-bridge…” as a hard drive but all the information is greyed out and unknown and I also cannot hear any clicks, but if I connect the HD directly to my PC I can see the HD is connected from the BIOS with name starting WDC…