Software won't install


#1

I bought the MY Book Essential 1TB just the other day. I was able to install it on both my laptop and my netbook, however, my desktop will not accept it at all. I have updated my computer etc. I have tried everything I can think of, although I am no computer whiz… Does anyone have any suggestions? As I said, I had no problems installing on my other two computers.

Appreciate any help anyone can give.

Colin.


#2

Have you tried contacting WD’s Technical Support? I would consider giving them a call about this.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#3

Colin,

Is the USB port live/active?  Does it work with other USB drive like flash?

Check Device manager to see if drive is seen under disk.

If yes, make sure formatted under Disk Manager.  Computer > Right click Manage > Disk manager.

Good luck.


#4

Thanks so much to both who replied. I think I have figured out my problem. Mind you, I haven’t really put it to the test yet!!!

“C”.


#5

Colin,

My info from www.wdc.com/wdproducts/updates/?family=wdsmartware

says to update the firmware first and update the software second.

However I can’t find any posts that are anything but reporting problems after updating the firmware, d:womanwink:o you know of any instructions that provide a positive outcome when one updates the firmware?

I could sure use them about now!

I hope you have your problem solved by now!

Thanks,

refreshing