Software Update - Windows WD SmartWare version 1.4.2.5 (10/21/10)


#1

WD is pleased to announce it’s latest software release, WD SmartWare for Windows version 1.4.2.5.  

Feel free to post your experiences here in this thread.

Windows WD SmartWare Version 1.4.2.5

http://www.wdc.com/wdproducts/wdsmartwareupdate/


#2

Memory Utilization Fixed ? , WELL DONE!! :slight_smile:


#3

just finished installing and rebooted my laptop… unfortunately it invariably crashed when I right click “WD Smartware” from the tray icon… Also crashed when launching “WD smartware.exe” from My Passport… Any suggestion ? I am so tired of not succeeding with this software…


#4

I have downloaded SmartWare version 1.4.2.5

When I started installing it I was told to disconnect all USB devices and then click Continue.

I disconnected all the USB’s, including my mouse, and then I could not click anything, because I didn’t have a mouse.

When I reconnected the mouse only, I was told again to disconnect all USB devices.

What can I do?


#5

Does this version work with .net 4.0? On the websites is mentioned that 1.3 of SmartWare does not work with .net 2.x and 4.x. But this is version 1.4.2.5.


#6

It should work with 4.0 , 3.5 , 3.0 , 2.0 , that version should not give any issues with the net framework…


#7

I just tried to update the software, and firmware, again, and it still will not update. 

I have the My Book Essential 1.5 TB, and since I first bought it about a year ago, it will not take an update to software, or firmware. 

My Norton 360 subscription just expired, and now, for the first time in about a year, my computer’s Sleep function works.  Can I have a “Halleu-jah!” 

Or, at least an “Amen!” 

I thought the WD software was causing a conflict with the sleep function, and I blamed everything on WD’s software, but I am partially correct.  Because now, the WD software still will not update.  I still have ver. 1.1.0.2, and cannot update to the latest ver. 2.0.1.0., or the software ver. 1.4.2.5… 

Do I have to go and find each update between ver. 1.1.0.2 to ver. 2.0.1.0, and install each one, before I install the latest update, or does the latest update incorporate all the previous versions, and I just have to figure out how to get that to install?  What do I have to do to get an update, when all the steps are taken, but after the re-start the update still is not there? 

Installing software is easy, except for WD software.  Now why is that not fixed? 


#8

OK, now this is getting weird. 

I now have to reply to my own posting on problems with updating software. 

While I was off looking into the WD forums for solutions, or for problems similar to mine, something happened to my WD Smarware software. 

I went back to the WD program to check whether there was any update done to the software.  The firmware version that is shown on the first screen after logging in, it still showed the old version of firmware. 

I was looking throught the various screens of info, I clicked the Setting tab, then the quick diagnostics, they call it the “Quick SMART Status,” I clicked that, and then the one below it.  While the second diagnostic test was running, I noticed on the bottom left-hand corner, below all the info on Product Name, Serial number, etc., it showed that the Firmware version was now ver. 2.0.1.0.  It did take the update, the second time I tried it today.  The Smartware ver. 1.4.2.5 also updated. 

Now I feel like an ■■■■■, after posting above on how this thing will not “take” an update.  So it must have been a problem with the Norton 360, even after I went into the Norton software and turned off everything I could turn off, some of it must have been on, and that interfered with the WD update. 

There is another problem with the WD software, it is really very slow.  You can click on something, and you have to sit and wait for it to take effect.  When something is that slow, you end up clicking it again, and again, you think it did not work because nothing is happening, but it is just really slow. 

There is a real need for WD staff to drink lots, and lots of coffee.  Maybe that will get them to work out why WD software works like it is on a Tandy 1000/286 computer.  And I have to look for another brand of virus software. 


#9

Western Digital updates are junk.  I have had it with the time consuming efforts trying to update.  I will be purchasing a different program and drive.

bill_s wrote:

WD is pleased to announce it’s latest software release, WD SmartWare for Windows version 1.4.2.5.  

 

Feel free to post your experiences here in this thread.

 

Windows WD SmartWare Version 1.4.2.5

http://www.wdc.com/wdproducts/wdsmartwareupdate/

 


#10

I tried but not work. Wasted  lots of time. WD is foolish to update with old net 3.0.


#11

I am sorry to hear that you are not able to get the update to work on your system. I recommend those steps, make sure you follow them thoroughly.

1- Uninstall WD Smartware current version installed. KB 5373

Title: How to uninstall WD SmartWare from Windows (7, Vista, or XP) and Mac OSX (10.4, 10.5, and 10.6)

Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=5373

2- Restart the computer. To make sure all residue has been removed from the previous version before going to the next step.

3- Download and reinstall the updated version from the Web site. 2nd step.

I get to work with several computer system. If you need further assistance, do not hesitate to reply.


#12

Thanks for responding.

I had nothing but headaches from the WD digital software.  The first time I tried updating the software, it would not take it, and it never worked properly.  It is supposed to work quietly, behind the scenes, doing backups all the time, but I had to unplug it to get it from constantly asking for a login. 

I tried 3 kinds of software to remove the WD software, to reload it.  The last one did work to remove it, but I still had to unplug it in between backups. 

Then, as I mentioned, when the Norton 360 subscription expired, the WD software worked better, and the sleep function on the computer worked again. 

I had to try twice to upgrade the software, the WD software is so slow, the update did not take effect for awhile.  In the past, when you clicked on the Backup button, nothing would happen, after a while you would see the number of files changing, then you would know the backup started. 

The slowness of the software is a little better now, but it is still slow.  I talked to a computer tech on this, he thinks it may be that WD software is Java-based, and that may be why it is so slow in responding. 

The Norton 360 is gone, I now use a free virus program, and that does not conflict with other software, so far. 

The bottom line for me is that I will never buy a WD product again, or Norton products, and as soon as I can afford it, this WD drive will either be a paper weight, or get used for hockey practice. 


#13

#14

Hello,

since i installed this firmware i cant use my logitech cam anylonger or wd drive (depends what was connected first).

Its one or the other device wich can be connected. And before changing a device, reboot is needed.

As soon as i connect the logitech cam/or wd drive i get a bluescreen (ks.sys).

Where can i download a older firmware for my drive? as it worked before without problems.

Thank you

DB


#15

1.4.2.5 release notes say ‘Fixed memory utilization issue’.   With 1.4.2.5 my Win7x64 system’s WDDMservice.exe gloms an additional 190MB to it’s working set each day. 

1.4.3.4 release notes say 'Fixed memory utilization issue.  With 1.4.3.4 my Win7x64 system’s WDDMservice.exe now gloms an additional 207MB per day.  

Have 2x2TB elites, 2x1.5TB essentials plus 3 smaller w/o smartware.  Went to 1.4.2.5 at same time as Win7x64pro from XPx32(x86)home and Memory utilization issue first noticed then.  

Pretty **bleep** embarrassing for WD.  Maybe have me give a beta try before posting next version that 'Fixed Memory Utilization Issue.


#16

WD Smartware Version 1.4.3.  After a solid week of trying to get the WD software to work on my Passport Essential 1 TerraByte drive, I have given up.  Four phone calls of over an hour each to Tech Support!  Net results: It doesn’t back up the large majority of my files, it doesn’t tell me that there were any problems during the backup, and it instead implies that it has done everything correctly with no errors.  If I was truly dependent on this software to have salvaged my files in the event of a PC crash, I would be in deep trouble right now.  The reps act like they don’t believe anything I tell them.  Their supervisor hung up on me when he said he would transfer me to Advanced Technical Support.

I am going to try and use Windows backup software.  If that doesn’t work, I am taking the drive back.


#17

I don’t think the Windows backup is what you want either. What are you trying to back up? Never trust importatn data to just one physical drive internal or external.

Joe


#18

WD smart ware is actually a very good product! I always hear people saying that it is glitchy and it is not so great but on my pc, it works fantasic!


#19

I’m glad you’re happy with it you’re in the minority. I can probably count the glowing posts like yours on one hand.

Joe


#20

well past smartware have a lot of errors, hope this version will fix all.  and one question, what does additional files means in backup tab under the drives label?