Software Update - WD SmartWare Version 1.6.4 for Windows (10/10/12)

WD is pleased to announce the release of its WD Smartware update for Windows.

You may post your experiences in this thread.

1 Like

What was fixed in this release?

According to the release notes: Fixed a bug where selecting a My Book Live drive on the Home tab would prompt the user for a password even though a password has not been set on the drive.

I uninstalled WD SmartWare, cleaned the registry, and did a fresh install of 1.6.4. When I launched the new version of SmartWare for the first time, my MyBookLive was set to the SmartWare share, which I have set to Private with users specified, but no password required. The drive showed a lock and when I clicked the drive icon, it asked for a username and password even though no password is set. In order to access the drive I had to enter one of the usernames and no password and then it allowed access. Shares that were set to public didn’t ask for a username and password. Subsequent SmartWare launches didn’t show a lock or ask for me to logon.

In my opinion there is still a major issue with this version of SmartWare! I’m using Windows 7 (x64) and I haven’t performed a complete checkout of this new version of SmartWare, but it is extremely disappointing that despite it being noted in the WD Community by others that SmartWare versions 1.6.X have an issue with deactivating a computer’s sleep feature, this version has the same issue. Even more troubling is with respect to version I also contacted Western Digital about the issue and was told they couldn’t duplicate the problem; I find that extremely hard to believe. It should be noted that I keep Backup stopped in Smartware and only start it when I actually want to perform a backup. In my case, if I want the computer’s sleep mode to work, I still have to launch Task Manager and stop the “WD Backup” service.

When I updated from 1.6.2 to 1.6.4 the Smartware does work anymore. So dé-install it then it works again. I did see MYBOOKLIVE in explorer. What is wrong?


I  just updated my WD SmartWare to version 1.6.4 and now when I launch SmartWare, on the Home page, My Book Live is locked and when I click on the image to unlock the drive, I receive a message stating: Authentication Failed  -  Access is denied. (Exception from HRESULT: 0X80070005 (E_ACCESSDENIED)). The issue is on my laptop, running Windows Vista. I have no issues on my 2 desktops, one running Windows 7 and the other one running Windows XP.

I also have the latest firmware installed for MyBookLive  -  version 02.32.05-046. Everything worked fine before I updated the WD SmartWare software. Help!

I updated yesterday in the hope that it would also fix the 50 Mb limit issue.  It didn’t…  :frowning:

I assume that everyone else is still seeing this?  WD Smartware doesn’t back up any file bigger than 50Mb, flagging it as “pending” and leaving it that way forever.  This makes the product useless for me.

I welcome “me too” comments, or even “wrong, works for me”.  :slight_smile:

Where do you see these warnings?

I have many files greater than 50 Mb and don’t see anything shown as pending in Smartware.

Thanks.  Could be good news.  I will retry.  I still had partial backups from the earlier version, but I thought I saw new ones appearing in the “Files Not Backed Up” area…  And they all get flagged as “File pending backup”

Backup started, will report later.  :slight_smile:

Nope, still no go.  Tried to backup a directory of Fawlty Towers, (240 Meg per episode), let it go all night, all were flagged as not backed up and pending…  :frowning:

Oh well, I guess I will be waiting for a new version.  Thanks for the comment.

I have now uninstalled the new version 1.6.4 and re-installed it. Thinking maybe something went wrong when I was updating but it did not help. The drive is still locked and will not unlock and doesn’t even give me an option to put in a password to unlock it. So I just uninstalled it again and installed the version I had previously which was 1.6.2 and now it works fine again. Of what I can see the new version 1.6.4 works fine on my computers that are running Windows XP and Windows 7 but doesn’t work on my computer that is running Windows Vista. But version 1.6.2 will work fine on my computer running Windows Vista.

So I have disabled the notification of updates on the software settings preferences and will continue to run version 1.6.2 until WD fixes the bugs in version 1.6.4. Hopefully that will be soon.

It seems ironic that version 1.6.4 was supposed to fix a bug in version 1.6.2 dealing with locked drives and I am having the opposite problem of having issues with a locked drive in the newer version 1.6.4 and no such issue in version 1.6.2!!!

Same happened to me. I finally downgraded again to 1.6.2 and everything works properly. I will skip the 1.6.4 upgrade.

It seems WD is going backward. Every time there is a new release it is worse than the previous one. The 1.6.4 is so far the worst. It took me over a week to resolve the issues with 1.6.2 and this one I expect is going to take longer. When is WD is going to invest a little more in their software engineers it remains a mystery. More people are being put off by the bad WD backup software they are buying other products. Would it be more profitable if WD software works and loyal customers can continue buying WD?

no issues here on xp, updated to latest release after formatting my 1Tb passport, had to clean put 1 tb of duplicated backups from my old drives, and although there was a delay in backing up the larger files and pst files. by that evening everything on both my drives was backed up.

i did run the netframework installer but as i already had it , it just did a repair.

what i found helped in the past was ti uninstall the old version, run the registry cleaner in ccleaner and then reinstall the software

also, once before it wouldnt back up a large movie file so i moved the file out and back into the same location which triggered the backup which worked fine, may not be practical with a load of large files

good luck

i’ve upgraded to version 1.6.4 and i had problems. When i click on disk icon i have to write user and password, and i’ve tried with all users and it didn’t work. I had go back to 1.6.2 version and now it’s working fine.

My sistem is windows vista home premium.

Facing same issue after installing update, any help.

I am having an issue with V1.6.4 finding a formatted partition ever since I updated. The SmartWare sees the drive, but does not see a formatted partition. I first tried deinstalling and reinstalling V1.6.4 and that didn’t help.  I had to roll back to V1.4.2.5 which was on the original disk that came with the drive. This fixed the problem but I’m now back on an older version.

I spoke to tech support today and  they told me that not many people are having this problem. Not sure if they are even working on a fix for this issue at this point and the tech couldn’t send me over to tier two for a status.

Does anyone else have this issue of the new version not finding a formatted partition?

Thanks in advance,



I did similar to what I did with V1.6.2 i.e remove this version, do ccleaner, and installed v1.6.4, then it worked fine for few  days but it stopped backing up again.  I removed it V1.6.2 and reinstalled again,and it worked fine for one day and then stopped again. So I went backward to v1.6.2. This had worked fine for a day and then stopped. It seems everytime the WDsoftware is removed and reinstalled it worked fine for a day or two and stops again.  The reasons for the un-backed up files are “Access is denied”, “The system cannot find the path specified” and the usual message “File Pending”.   I don’t believe is is too difficult for WD to resolve these issues, and the issue of the WDSmartWare in general.  If they fix WDSmartWare I don’t mind paying extra few £s for the drive and not waste time. I would like someone from WD to comment please.

Also the issue with not allowing the PC to go to sleep remains an issue and despite writing e-mails to WD several weeks ago I still had no response.

I guess you have Windows XP and it seems to work with XP with a little bit of adjustments. I have Windows 7, and I am sure most of the people using WD who are having a problem with WDSmartWare are using Windows 7. 


hi mate, it still seems to be a big problem with the smartware, i must admit mine is faultless on xp.

i had just formatted my drive for other reasons when i upgraded to the new version, but within a few hours it was fine with everything backed up and no cpu issues.

i did get some good input from one of the WD staff when i submitted a support email, the result of which i posted somewhere in the previous thread, which did seem to sort a few people but it seems like with a new release comes new problems not seen before.

i would advise anyone to try and contact the WD support via email and see how it goes. i have had very good results to no response at all in the past so a bit of pot luck.

i am finding it hard to help people as i haven’t had the issues they are having so haven’t worked out a solution.

the link below is to an earlier thread which in turn links back to the post i copied from the support email i received

hope it helps someone

its my post that starts hi giribit