Software shows on My Computer but files don't

Hey Guys,

So I have been using the My Book Elite for sometime now with no problems until Friday last week. Before I would connect the unit, power up and enter my password to unlock it, the software would popup and I would always close it and access my files through My Computer under drive labeled G.

As of Friday the process is the same until I get to My Computer; there is no longer a G drive (Which only showed my files I’ve added and that’s it) but only an E drive labeled as WD Smartware which was not there before and only has the pre-installed software (which didn’t show before).

I know it didn’t loose the files because this is a 1.5 TB drive and I still have 1.19 left. Under the WD Software under Retrieve I can’t select anything but its not greyer out. I’ve updated the software and my windows 7 software and have also uninstalled this unit twice.

Any thoughts?

Go into disk management and see if it is recognized there. It may have lost it’s name,


1 Like

Thanks for the help Joe,

This worked just fine and no (unfortunately) I can get my job done…

? Any thoughts as to why this would happen, why would it loose the letter ?

Thanks again…


I don’t know why. When you revome the drive always do it properly clicking on the icon and eject the drive. Do you use a third party defrag program? That caused me some trouble on a MY Book Pro.


Re: Software shows on My Computer but files don’t

I faced a smilar problem that NateH faced. But in my case, the drive letter is visible. However when I try to access the data, the Windows Explorer hangs. I tried using your suggestion to check the disk healthiness in disk management.

The J Drive representing the WD Ext. Drive is visible and is shown as Healthy.

Also the bar indicator on the external HDD shows the drive is empty.

I can’t seem to figure out what could have gone wrong

Did you try running chkdsk on it?  The drive often gets “damaged” if not safely removed.

If that’s all that’s happened, chkdsk will generally get it up and running again.