Software Corrupted, unable to reinstall

The WD software for My Book drive failed last week with the error, “WD SmartWare encountered a problem and needs to shut down” or something to that effect.  Nothing in the details/

I uninstalled and reinstalled the software from the My Book, it asked me to restart the computer, which I did.  When I attempt to run the application it gives me the same error message as above.  I unintalled the software and rebooted.

Downloaded the software from the WD site, copied over to the My Book, ran the install, same issue as above.

Now what?!?  This is WinXP SP3, Lenovo T410 with 4 gigs Ram.

O ne more step…I just finished up-dating the firmware thinking that this might have been an issue.  Firmware updated correctly with no issues.  Rebooted and reinstalled from the downloaded files.  Same error.


Try uninstalling software and disabling your AV when you reinstall the software.


do you have the latest Java and .Net framework installed on your pc?  that could definitely hinder the software from even starting up.