SN750 and Windows stornvme.sys BSOD error (with no workaround)

I am baffled with a stornvme.sys error which has forced me to abandon windows for Linux (for now). This is what happened prior to the issue, and what I have done trying to recover from this (all unsuccessfully). I would love if anyone knows how to resolve this problem.

I was running Windows 11, insider, on my PC that is built with an ASUS X570-E motherboard, ASUS Nvidia 2070S GPU, 32 Gigs of Ram, and the main disk was my SN750 NVME drive.

I was getting a few disk errors that I felt had something to do with my PC setup as it wasn’t isolated to my SN750 drive. Regardless, since most of my drives are WD drives, I tried to run Dashboard to check my drive specs… but I just got a BLANK window (a known issue with Windows 11 apparently).

I booted to safe mode in Windows 11 to see if dashboard worked, and happily it displayed. I noticed there was a “game mode” option that was not enabled. Since my PC is used a lot for gaming, it made sense to turn that on. I enabled Game Mode. I was told to restart.

Upon restart - I got the blue screen shown in the image – system thread exception not handled - stornvme.sys

The error came up immediately within 30 seconds of Windows booting. I didn’t get a chance to go through any boot procedure, and consequently could not capture any log files.

Naturally, I tried to go to recovery but I received the same blue screen immediately as it tried to load recovery.

Flustered by this, I created installation media and booted from the installation media – same blue screen.

I did this over and over, with different combinations of windows boot disks – USB boot drives from windows 10, 11, windows PE… all the same error screen. I even burned a rescue DVD and reinstalled a DVD player so I could boot from it… but to no success.

I knew it couldn’t be the windows registry, as it was happening with the rescue USB sticks as well, but without any other options, I booted into Linux live usb and restored the entire registry from my previous backup… rebooted and the same blue screen. I went back to the linux live disk and used the mbr boot-repair. It said it fixed some things, but I still got the blue screen.

Next I re-seated my memory DIMMS. I moved the NVME drive from M.2_1, to M.2_2 but still received the blue screen immediately.

I disconnected ALL other drives and devices thinking that maybe I have a rogue mbr on another disk… same blue screen using any boot.

I am now completely flustered. I felt my only option was to reformat the NVME and then restore windows using a boot disk as this would have to fix the issue, but no… same blue screen but now I purged my entire install / system drive and it didn’t help. :frowning:

I ran Long Extended drive tests from BIOS… everything passed. I disabled legacy CSM mode… nothing… blue screen.

There is nothing I could do to even boot recovery level windows. I couldn’t use a boot disk or install media.

I am writing this post from Ubuntu Linux installed onto the same SN750 drive and it works without issue (in fact, everything works really well). I can only assume that whatever was selected when I choose game mode resulted in the drive being reconfigured that didn’t seem to work with Windows. I have NO idea how to potentially reset the drive to default settings, or remove game mode since I can’t get a windows session running in any form.

I have pondered installing virtualbox in Linux, and installing a windows VM and see if that runs and allows me to run dashboard but I think it might be a stretch.

Has anyone else run into this level of failure with regard to this drive and windows, where there was no workaround? Does anyone know how I could potentially reset this drive?

I tried NVME-CLI in Linux, but couldn’t find any proper option to change the drive.

Thanks for the long read, and look forward to any thoughts folks might have.

Hi @redlow,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Thanks for the reply. Yes, I also opened a case. I thought either someone would know what is going on, or if not, and I did find out I could update here to help others since I found no other reference that was really similar to this. All others seemed to be able to access recovery

It sounds like you’ve already tried a lot of troubleshooting steps, but unfortunately haven’t been able to resolve the issue with stornvme.sys. Here are a few more potential solutions you can try:

  1. Update your motherboard BIOS and NVMe SSD firmware: Sometimes outdated firmware can cause issues with your NVMe drive. Check your motherboard and NVMe drive manufacturer’s websites for any updates that may be available.
  2. Try booting into Safe Mode: If you haven’t already, try booting into Safe Mode to see if you can access the Windows installation. From there, you may be able to remove any recently installed updates or programs that could be causing the issue.
  3. Check for corrupt system files: Open a Command Prompt as an administrator and run the following command: “sfc /scannow”. This will scan your system for corrupt system files and attempt to repair them.
  4. Try a different NVMe drive: If you have another NVMe drive available, try installing Windows onto that drive to see if the issue is specific to your SN750.
  5. Contact manufacturer support: If none of the above solutions work, it may be worth reaching out to the manufacturer of your NVMe drive or motherboard for further support.

Hopefully one of these solutions will help resolve your issue with stornvme.sys. Good luck!