SN720 and bitlocker issues

Hi all !
I am trying to reset a SN720 with bitlocker.
Tried first on the laptop (X1 Carbon 6th gen), but got no way to reset to fabric the laptop. Please note:

  • I have the bitlocker key so I could xcopy from CMD window the entire disk, so no troubles with the data.
  • I tried various ways (external win10 USBkey, internal win10 recovery, etc), no way. The OS stuck while (i suppose) deleting the partitions.
  • I got an external USB box to handle the SSD on another PC. Tried various utilities (OS cleandisk, partiton magic, minitool partition), unable to remove the partitions on the disk. It seem to be HW locked in some way
  • installed on a laptop the Western Digital “Data lifeguard diagnostic” . The SN720 on the external USB shows up (with a little yellow lock), passes the extended test (Health status:“warning” but quick and extended tests are OK). Tried to “erase” the entire disk, the utility fails immediately with error “20-delete partition error”

Any idea ? the SSD is not that old (Dec 2018)…

TY, ciao from Italy


Does your SN720 have a PSID printed on the label? If so, you may be able to do PSID Revert.
The Dashboard utility will perform the PSID Revert if your drive supports it. The option will appear under Erase Drive tab, within Tools section.

Yes, the device has a PSID!
I downloaded the dashboard utility. Unfortunately, Erase Drive Tab recognizes th SSD (USB 3.0, serial nr.) but shows no buttons to do anything. I suppose could be the adapter box used (Eleuteng M.2 NVME to USB), I will try to find anoter adapter by tomorrow, or insert the drive in another laptop with a M.2 slot.
Let U know ASAP, TY

So, here the results:

  • first I inserted the drive in the original laptop, recognising it through BIOS and system
  • then, I started the laptop with an external USB win10 bootable key, containing the dashboard. Key built with RUFUS. Took a long time to boot, finally I could install the dashboard.
  • disk is “critical” !
  • Under “tools” there is no PSID Revert button or link ! Strange… version is, up to date
  • under “tools-erase” The APP says is unable to “sanitize” the drive. the only other option was to create a “sanitize USB bootable key”. Did it, on a 4GB Key (no way to know how big it should be…). The system tells me, after preparing, everything is ok so I can remove the key. But the key won’t boot. I repeated the step twice (creating-booting). So no way to clean :frowning:

really don’t know what’s next. Before asking for a warranty replace, what’s next IYHO?

Ty, ciao


PSID Revert not showing up might mean that the device is not actually locked or that some other setting will block the Erase. It should have shown up in the same screen as Sanitize if it was available.

The USB boot you have to be careful that your USB key is booting in UEFI mode. The Linux image that is created will only work in UEFI mode.

Once you are able to boot the USB tool you can also select PSID Revert if you want to try it, by the way. There will be a field for you to key in your PSID in the tool if you select the PSID Revert operation.

Be very careful when changing the disk you have selected in the USB tool though. You can select any disk by serial number so do not erase the wrong disk!

If you cannot get the USB to work from Dashboard or only have BIOS mode, you might want to try booting to a Ubuntu USB boot, which you can also create with Rufus after downloading the Ubuntu Linux ISO from Ubuntu website. From there you can use a number of open source tools to try to erase your drive, like nvme-cli for Sanitize or sedutil for PSID Revert.

Also, there is another user who got the BIOS mode USB to boot, but had to use Ubuntu image to format the key.


Just to inform you that I run a HW check from Lenovo, and the disk appear to be defective, so I got a new one.
TY anyway for your precious help, stay safe and take care