SN570 2TB causing blue screens when formatted to 4k sectors

I recently bought a 2TB WD Blue SN570 SSD, and formatted it to 4k sectors (nvme format -l1 -f /dev/nvme0n1 from Linux live CD). When I tried to use this drive in HP EliteBook 855 G8 laptop, the computer would bluescreen before reaching the Windows login prompt, and afterwards the BIOS warned me that DMA protection was triggered (I originally cloned another drive to this one, but after I tried doing a clean Windows 10 install, it would bluescreen after the first reboot). I also tried the same drive in another machine (Intel’s 6th gen NUC), which had the same symptoms.

I tried replacing the drive, and the replacement drive was even worse – it caused the computer to reset while I was cloning the original drive under Linux. I then put the drive in yet another machine, updated to the latest firmware with Dashboard, and then tried using it in original computer. This appeared to work for a few days, but then I started getting blue screens and DMA protection problems again.

Finally I formatted the drive back to 512-byte sectors, and the drive seems to be stable now (but I’ve been unable to clone the original drive I used, since that one was on 4k native sectors).

Hi @_ender,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Considering how unhelpful the support was last time I opened a support case (WD Dashboard crashing my Areca RAID controller, their response was “use a different computer”), no.