SMP settings are not being saved. (Issue occured after i performed a hard reset)

I had performed hard reset on my SMP today. After that when my SMP came back up none of my settings are being saved.

Foe example, I enabled media library as on and get content info in Auot mode and restart the devive from System-System Restart. Once the system is back on all the settings i made above are gone back to origianl (i.e. Media Library to off and get content info to Manaul)


What version of firmware?

firmware - 1.09.10

By hard reset, do you mean by pressing the button?  Or using which of the menu options?

by pressing button in the hold (using a pin).

After that when i saw that settings are not saved, i tried reset under the system menu as well.

That sounds like basically what was happening to me in my post.  I am downgrading the firmware as suggested to see if that works, will know shortly.

firmware downgrade did not help me, still not saving settings for media library.  Mine is opposite if yours, it is on and the and content info is auto, no matter what I can’t get those settings to save when I change them.

I also tried downgrading to 1.08.17. Then tried changing a system settings, after reboot settings are gone back to original (tried setting HDMI sec as on and gone to off after reboot)

Installed 1.09.10 and then tried again HDMI sec settings. No go.

some thing bad with my unit.