SMP lock ups/disconnecting HD

My SMP has been locking up/freezing while looking at  and scrolling through media.

It has happened twice in the past hour and a half.  

Shortly after it freezes it will display this message:

“Please safely eject your USB device before removing it.” "Choose a new content source since

the original content source has been disconnected." 

Once this error occurs the external HD is no longer seen by the SMP. 

I’m using a WD 3TB My Book Essential HD. I am running 1.05.18 firmware.

I did not have this issue before when I was using my 3TB Seagate and the previous firmware (1.03.071)

So I’m wondering if this is a firmware issue or HD issue since those are the only two things on my set-up that changed.

Perhaps my SMP randomly decided to **bleep** out - that’s very likely as well. *Shrugs*

Either way this is not something I can live with. ;()

Any thoughts?


I’m experiencing the same problem with fw 1.05 for the last two weeks. The only thing that’s changed was the fw.

1 Like

After this error message on the SMP  - I plug my 3TB HD back into my notebook and I see this
message pop up.

"Do you want to scan and fix My Book (E:)?
“There might be a problem with some files on this device or disc. This can happen if you remove the device or disc before all files have been written to it.”

“Scan and Fix”
“Continue without scanning”
Are the options.

The “Scan and Fix” reports no issues with the drive, but if this is a firmware issue - It’s most likely going to happen fairly often and I don’t want to open up the possibility of causing damage to my data on the HD. I may just wait for a new firmware for the SMP…

Is there a way to roll-back in firmware? Factory reset? I think there’s a reset button on the SMP you can hit with a pin. 

1 Like

Hate to be a party pooper, but I went back to 1.04 and still have the same issues…

We are not alone… :smiley:


With my 3TB Seagate I was running firmware 1.03.07i.
Zero issues…
I did not use 1.04 firmware. The SMP just updated directly to 1.05.

Well this is quite disgusting - If what you say is true I can’t even downgrade to the 1.04 firmware to fix this issue - ultimately making the SMP an over-priced paper weight for now.

I have never had to do so much trouble shooting in my life to get a piece of hardware working. It’s just unreal.
I should have just bought 2 1TB HD’s and connected them directly to my TV being that most TV’s can’t recognize 2-3TB drives. Though it seemed ridiculous to buy less storage space than I desired. *sigh*

If anyone has an update on this issue/advice i’d like to hear it. Thanks!

I’m getting the same exact problem.  My external drive worked (and still works) great on my older WDTV Live Plus, but on this new SMP after watching a few files or trying to copy files to it, suddenly it acts like the drive is ejected.  Only way to gain access to the drive again is to physically unplug the power from the SMP and reboot it.  That’s very inconvenient and just plain wacky.  Surely, WD can do better than this.

1 Like

So has anyone who is having this issue tried the new firmware? I know there was no mention of a fix for this in the most recent 1.06 firmware notes, but you never know…
I’d give it a go but I’m out of town on business so I can’t try 'till the weekend.

I also submitted a help ticket to WD on this issue, but no feedback yet… I will keep everyone in the loop if I come across any information. It **bleep** for me because I have 2 brand new 3TB WD drives and I can’t even use them on the SMP.

Don’t get your hopes up…

I updated after work this evening and it locked up a .mkv file in less than 20 minutes played off my USB like it has in the past.  I have not reset the player, as I just rebooted it and am now watching a streamed DVD with the family.

I will report more when I have the chance to fully test it.


After upgrading to the latest firmware I did not have the problem until today.  I turn on my TV and there is the “select another source” message.  Granted, this means the problem is not as frequent, but it does still exist.