SMBD not running or installed when trying to set up HD Homerun DVR...Help

I am trying to set up HD Homerun DVR and keep getting the error message SMBD not running or installed. I would appreciate any help with this, I would love to send my cable company dvr back to them since I have had to replace three of them.

What My Cloud model do you have?

There is a similar discussion from last year over on the Silicondust support forum. See the following link for a possible solution on the My Cloud.

by nam6869 » Mon Mar 07, 2016 5:05 pm

I had the problem with a MyCloud –

A third level WD tech helped me fix the problem.
Turned SSH off and rebooted the MyCloud
Set up the HD share manually.
Turned SSH on
Used Putty, signed in to the MyCloud LINUX partition
used MyCloud IP address and the generic user/PW WD reported when turning SSH on
Request to change PW came up
Closed Putty
Ran the HD set up
NAS Install
It worked/works
I guess signing into the LINUX partition with SSH reenabled the SAMBA – I’m not technical enough to know much more that it worked.

My post on this forum
Don’t know if it will work for you but it’s pretty easy to try. You can get Putty at

We have the 4 TB, WDBCTL0040HWT.