SMB protocol only works when internet connection is available!


#1

Hello
recently i have updated my mycloud EX2 to the latest Version .
everything works great and it has better performance in the latest firmware . but unfortunately the SAMBA protocol only works when the EX2 has internet connection.
I dont want to use cloud features of mycloud EX2 . i just want to use its NAS features in my lan and put it behind the firewall for extra protection
but when i disconnect the internet from the my cloud EX2 on NAS OS3 . the shared directories are not available via SMB protocol on SMB version 1,2 or 3
other protocols such as Webdave , NFS , FTP works and i can see the dashboard in my browser.
but the PCs in the same Subnet don’t see the EX2 via the SMB protocol !
As soon as i disconnect the WAN port from my router the SMB protocol Stop working
this should not happen in a LAN !! What is the problem ?
I didn’t have such problem before update to nas os3 ?


EX2 SMB Problem not solved in the new firmware!
#2

Hi david001

what exactly did you do? Did you stopped the Cloud-Service by setting its state to OFF?
I don’t understand what you mean by “disconnect the internet” as the EX2 should be part of your internal network.


#3

I did test it in both mode
mycloud service “on” and mycloud service “off” mode,in both modes the SMB access will not work when the internet access in disconnected
all of my devices are in the same subnet 10.10.10.0/27 , i don’t understand too !
i didnot have such problem before updating to the nas os3 2.10.310. the ex2 was always behind a firewall and everything was working
nothing changed in my network except the firmware version . and only the SMB protocol has the problem
everything else works fine !


#4

I too don’t understand what you mean by “disconnect the internet”. Like Joerg_A, it is unclear to me too EXACTLY what you are doing when you say you “disconnect the Internet”…even after reading your clarification comment. But I can definitely say SMB protocol should work regardless of whether the router to which your EX2 is connected to, is connected to the Internet or not. SMB works on local network, not Internet (WAN)…so being connected or not to Internet should make no difference. But because I am unclear about what exactly you mean by Internet access being disconnected, I cannot provide anything helpful to resolve your issue. You will need to clarify more what exactly you are doing when you “disconnect the Internet” from your EX2…how exactly do you disconnect it? You need to describe THAT better before you can expect a good answer…the more info you give, the more precise answers you’ll get.


#5

The Mycloud EX2 and my other devices are connected to my Gigabit Wireless Router
My subnet is 10.10.10.0/27

mycloud has the IP 10.10.10.13 and the wireless router is the gateway with IP 10.10.10.1

I’m using SMB protocol to access my shared folders in EX2

As you said SMB protocol should work in internal network with the same subnet

before updating the EX2 , the EX2 was always behind the firewall and i was accessing it from internet via VPN connection into my network.

i just update it into the latest firmware. NAS OS3. but now when there is no internet access on the device i cannot access the shared folder via SMB protocol

other porotocol such as webdave , FTP , NFS , dashboard , DLNA works and i can ping it in < 1ms only SMB stop working

I did disable the firewall,there is no policy and rule in my network ,it’s just a simple LAN

when the ex2 has internet access i can see the SMB://10.10.10.13 shared folders and i can access my files with Gigabit Speed.

imagine that as soon as i disconnect the ADSL/WAN cable the SMB stop working on the EX2

i did connect it directly to my PC and the same happend again ! SMB didn’t work

it is starnge for me too, i don’t understand why such thing happen !!
I just Update it Via the the EX2 Update file , i didnot factory reset it after update becouse i have many configurations in accessing shared folders

i think i explened it well. please test it with your own device, and tell me do you have such problem with SMB? do i need to enbale/disable anything ?


#6

Hi David

i have never heard similar issues, so I need to ask for more details; I still don’t understand what happens on your network.

What is your router (manufacturer, article name, firmware version)?
Are you using an additional switch (if yes, is it a managable switich; manufacturer and name)
Are you using IPv4 or IPV6 or both IPv4 and IPv6?
Are you using DS-Lite, Dual Stack Lite, on your internet line? If yes, who is your provider?

Can you send details about the IP setup of your EX2? DHCP-IP or Static IP; if Static, please all details with Gateway and the DNS server settings

Is this setup still vaild? Who is handling the VPN tunnel?

next test, depending on the operating system of your client:
If you unplug the WAN port, you write, that dlna, FTP, dashboard etc. are still accessible, so TCP/IP stack is still up and running. PING is also still working as you write.

PING again the EX2 and then “ARP -a” right after the PING. Please post this ARP -a result.
ARP should give you back, who else is involved in the packet transport from your client to the EX2.


#7

I had exactly the same issue with MyCloud EX2 (the latest firmware) - the Samba shares could not be accessed when my router’s WAN connection was down. Similarly to OP I don’t use any cloud features.

The cause of the issue is the configuration of the Samba server on MyCloud which for god-knows-what reason needs an accessible DNS server to work. So here’s what I did:

I set MyCloud to use my router as the DNS server via static IPv4 configuration - so if your router has IP address 192.168.1.1, just enter 192.168.1.1 in the DNS field. After making this little change the Samba shares could be accessed even without the Internet connectivity - although opening them takes a bit longer (probably because of some DNS timeouts).

This solution may or may not work for you depending on whether your router can act as the local DNS server.

Hope this helps if anyone else encounters this frustrating issue ignored by WD.


EX2 SMB Problem not solved in the new firmware!
#8

hello
thanks for your solution, as you said it may work , always my dns server was the router IP
i did factory default reset the EX2 , and reconfig it to fix the problem
after the newest firmware update , the problem happens again.
you must factory reset and then reconfig the device.restoring backup file does not fix the problem

The WD developers should fix this bug in SMB protocol


#9

I have same problem.
Just remove getaway and DNS from NAS Network settings.
Only have to write IP and Mask
For example
192.168.0.17
255.255.255.0


#10

this is probably rare for some due to internet connectivity does not go out to much and maybe the ones that do dont update the FW but has WD actually tested updating the FW and disconnecting from the internet to test that SMB still is functional?
It was working fine for me until i updated the FW in January. I can factory reset to resolve but rather have the updates due to security and bug fixes…any suggestions?