SMB not working with non-default device name

Hi,

I updated to version 2.31.149 and since then I wasn’t able to connect to my device via SMB with Windows 10. FTP and SSH were still working. I tried a lot of things including system reset, but nothing seemed to work. Then I made a second system reset and “forgot” to change the device name. So I tried connecting with the default device name “MyCloudEX2Ultra” and it worked. The strange thing is, that it is the same with the IP. If the device name is default then it works with the local device IP. But if the device name is a custom name it doesn’t work with the IP either. The device was during testing directly connected to my PC with static IP. No router firewall or something similar between. It’s also not a “Windows thing”. I tested with a linux system and “smbclient” too. The same behavior.

Can someone explain me that strange behavior? Is there a fix for that problem? Maybe there is a setting I can set direct via SSH?

Thanks in advance!

Maas

After some checking I found out that the MyCloud system is not updating the /etc/hosts file when changing the device name via web interface. There, the old default name still exists for 127.0.1.1 entry. After manually changing the value to the current custom device name everything works as expected. It took me a lot of time, because I never expected such a “facepalm”-bug from a big player like WD. Sorry WD, but this is just bad programming.