Smashed external enclosure

I have a  MyBook Studio. The casing is broken after a bike accident. We tried putting it back together and powering it up, but no joy. I have taken the drive out of the enclosure and have tried connecting it with a connect-all cable that I have for migrating etc. I also plugged it straight into my macpro. It sees the drive with both but does not mount it - it says ‘The disk you inserted was not readable by this computer’. I presume the hardware security is the issue here. I know the password, but have no opportunity to input it.
Any advice? I really think the drive itself is fine. No nasty noises. I have another drive to clone it to (WD too!). It’s a backup disk and I reckon there is a lot of unique data on it, so would like to access it
Any help here would be great.

Dude, I’m sorry to tell you that you can only access the drive using the password on the original case with the original controller, so anything else is not going to work. Your best bet is to zero the drive out with the erase function of disk utility, and then format it so you can start from scratch.