Smartware won't update on Mac 10.4.11


#1

Hi,

I recently purchased a Passport drive (not the Mac-specific one, which I didn’t know existed until right now) and I’m having a heck of a time getting the Smartware software to update.  Whenever I try to use the installer to get to 1.1.1.3, it freezes at the end of the install, goes to Application not responding, and never prompts me for the reboot that it says it will on the support page for the update.  I have let it go overnight and it still never prompts me to do anything. 

Any suggestions?  I’ve tried removing the software and the plists a couple of times now, and no matter what I do I can’t get anything to save on the passport or the software to update.

Thanks,

James 


#2

Have you tried contacting WD’s Technical Support? I would consider giving them a call about this.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#3

Do you have a PowerPC MAC?

If so, you cannot update past 1.1.1.3 because of the system configuration. I think, but don’t quote me in this, it must be an Intel-Based MAC.

Did you also perform the firmware update?

Try reformatting the drive in DIsk Utility for 1 partition, MAC OS EXT JOURNALED, Option: APPLE PARTITION MAP, then reboot.