Smartware Will Not Access MyCloud

I have a typical setup:
Laptop-Win 10-Mcafee-Router-MyCloud 4TB single volume.
MyCloud has Users and Shares. Dashboard works fine.
Shares are visible on devices. Port Forwarding is setup.
Smartware reads laptop drives but will not log onto MyCloud
or allow requesting update to Pro version.
You can see the button presses but no action and no error message.

Right Click on WDMyCloud Icon Properties correctly identifies MyCloud details.

Question:
What Workgroup ID is Smartware looking for?
_My Win 10 User Name?
_Admin off MyCloud?

Any other suggestions (everything has been reinstalled, reset, etc)

I have no luck with several calls to Level 1 support and have been waiting three days for Level 2 call me back.

  1. The logon to MyCloud is a local API call and you must use the Admin user name and password of MyCloud device
  2. The request to update Pro Version is not a software update, but a call to the Smartware license service.
    This means there’s a network issue between your Windows PC were Smartware is installed and the license server which is smartware.wdc.com

from your PC, you should be able to:

nslookup smartware.wdc.com
ping smartware.wdc.com
tracert smartware.wdc.com

Thanks for the suggestions


nslookup 129.253.55. 147, 148, 149, 150, 158, 159, 172
Ping 129.253.55.150 Average 64ms
Tracert 129.253.55.150 14 hops

WDMyCloud (local 192.168.1.112)
Can Ping and Tracert
but not nslookup

Also, I have Port Forwarded only HTTP and HTTPS, and not FTP
(now have added FTP 20 and 21)

When you open up SmartWare, have you read all of the Help information provided in the Help tab?

I did not see any useful information about this issue in Help. If there were I would expect that at least one of the level 1 agents would have noted it.

What version of SmartWare do you have? Are you able to provide any images of what is showing when you have SmartWare open and on the Home tab?

Version 2.4.16 - downloaded by WD during chat session.
SmartWare Home looks normal (I was using it routinely until this issue came along) - not sure how to attach a pic here.

You may want to use the Problem Steps Recorder and forward the results to WD. See example image below.

Click on, tap or activate image to enlarge it.

@wdhewitt looks like you can ping and trace to the smartware activation server.
But you did mention " Port Forwarding is setup.
Smartware reads laptop drives but will not log onto MyCloud
or allow requesting update to Pro version" which tells me that there is something regarding the router that could be a problem.

What DNS server is your router, PC and My Cloud using?

If the DNS server is the Mcafee-Router, it could apply some local dns filtering or blocking.
Try changing to Google 8.8.8.8 and 8.8.4.4 on all three and reboot. This will bypass the Mcafee-Router if it is blocking or filtering local DNS queries. Google and TPLink OnHub routers do this.

Since you mentioned “Port Forwarding is Setup”. I’m assuming that your router is not using uPnP which would
automatically set port forwarding unless the unit in double NAT’d or behind more than one firewall. It’s possible
the Smartware server is not being allowed into your network to apply the license."

@SBrown
I am using 8.8.8.8 and I notice it calls on 8.8.4.4.
I will change all to those two but can’t try it until Tuesday as I am on the road.
I had noted in another post that the firewall and router logs show no blocks during the testing.

I set up port forwarding manually based on some reading I had done. I will try with and without.

@SBrown
I checked that the router was using uPnP and removed the manual port forwarding.
I set two DNS to 8.8.8.8 and one to 8.8.4.4
This let the Smartware server send the activation codes so I now have Smartware Pro. Thanks for the suggestion.

I spent 3 hours on the phone with advanced support and two laptops this morning to no avail. There is still something in Win 10 not letting my laptop properly access MyCloud. The Win 7 laptop works just fine.

I am currently in process of cleaning up my admin userID to see if we can connect using it.

I found some instances where UDP port 1900 was refused but have yet to find any rule or setting which would have done that.

@wdhewitt happy to here things worked out for you.
Regarding Windows 10, when Netbios over TCP

  • From the Network and Dial-up Connections icon in Control Panel , select Local Area Connection and right-click Properties .
  • On the General tab, click Internet Protocol (TCP/IP) in the list of components, and click the Properties button.
  • Click the Advanced button.
  • Click the WINS tab.