Smartware v2.4.21.1 backup targets blank, buttons greyed out


System specs: Win10, 64bit machine


  1. Ever since I upgraded software versions I’ve been unable to use the GUI to modify/change my backup targets such as files and folders. Let alone see them. See uploaded/attached image.
  2. In the previous working versions I had already setup my backup targets, file paths to backup etc. this incredibly still works behind the scenes. So even though the GUI is broken, my files are still backing up/synchronising.

Current status: Unsolved. It still backs up, just can’t use the GUI to change things.

Any ideas on what to try, test, reconfigure?

@Doombringer2019 Have you looked at the information provided under the Help tab? Here is a link to the User Manual too.

If using the above does not work then try the Control Panel>Programs>Uninstall a program, select WD SmartWare and at the top try Repair. See if that solves your problem.

Hi Cat,

Thanks for the response. The user manual did not cover off on the issue.
I reinstalled a few times. Issue still present.

Easiest way to get around it is to open and close it. They momentarily come up online for a 20-60 seconds before they drop off again. Then you close and reopen smartware and they work again for the same period of time. During this time you can still access the mapped drives and pinging the devices still works fine, no interruptions. I’m guessing something internal is causing them to drop in and out.

When they are appearing I configure the folders to backup and enable it. It works fine and runs in the background, you just can’t see the backup targets in the GUI. Again if I close and reopen, they come back.

I haven’t touched with any router settings either and they have not dropped off the network as I can ping them fine.

Any ideas on what it could be?

No idea, mine works fine and I have it on both my Desktop and Laptop, both Dell computers, Laptop has 16 GB or RAM, Desktop has 32 GB of RAM and 16 GB of Intel Optane Memory. Both have Windows 10 with all updates.

I do use scheduled backups for both of my My Clouds.

Did you try Repair?

Hey Cat,

Yes tried repair also, I hope they release another firmware update.
My win 10 is up to date also.

Is there a way to raise the case with WD software support. Or is it simply too small of an issue for their team to look at?



What is showing under your backup source, which drive?

This is mine. Click on, tap or activate image to enlarge it.

Hey Cat,

Yes I do get the same as you. However, both drives drop off and the top tabs become greyed out. When they are available I can click on a drive and use the tabs.

Essentially the drives disappear intermittently. I can restart my PC and they reappear or I can open and close smartware a few times and they come back.


Hey Doombringer2019
I have exactly the same issue,
Did you finally found a solution to solve this please?

Hey Fizzzz,

It turns out it was another backup utility I run to another cloud application causing a lag. So I changed the setting from the automatic backup upon file change detection to hourly backup for each. Seems to be fine for the past year.

Hey Doom,

Thank you very much for your help.

Fact is I have another cloud backup utility (Norton) running and set to automatic mode.
I’ve turned it off, reboot, but the problem is still the same…

I’ve noticed that it’s not only with WDsmartware,
WD quickview is also “loosing” the NAS.
What a nightmare!

Oh no, that doesn’t sound good.
Perhaps something else chewing HD or RAM usage?
You probably already disabled Norton backup, not sure what else you can try though.
If you reboot does it un-grey and then after a few moments grey out again. Or is it greyed out at bootup.
Perhaps disabling other applications at startup may help. Which ones to disable will be a bit of a question mark though.

Alas “greyed out” issue seems to appear totally randomly,
this morning, I had the chance that it stayed connected with WDsmartware during 15 minutes,
then I’ve been able to modify folders to backup.
I can see that the backup size has increased, this means that back is working.
But I’m not able to check if Restore would work since it turn to grey before I can browse the content…
Yet, the NAS seems to work fine with File Explorer and with Plex server…
(Plex application shouldn’t be the cause of issue since I’ve installed it after the issue)
I can’t find any logical there, and I don’t know which application at startup I could disable…
Thanks for your kind help.