Smartware unable to find MyCloudMirror

Whilst I was able to get through my last problem by reaching, I am stuck on this one.

I have downloaded ‘Smartware’ and ‘Quickview’ but when I go into ‘Smartware’, the only option it gives me is Dropbox. MyCloudMirror is no where to be seen.

I have searched in the community and found one possible answer that unfortunately didn’t work.

I already have ‘turn on network discovery’ ticked.

I uninstalled Smartware and Quick view and reloaded them but still no where to be seen.

I am running windows 7 - 32bit, my router is only a year or so old. Everything is up to date.

MyCloudMirror was setup yesterday and other than this problem seems to be working fine.

I would be grateful for any suggestions so I can start backing up.


‘Put me in the dark and I will find some light’

A couple of quick questions/tests:

* Can you see the MCM via other means (for example under your network can you access the shares directly)?

* Can you access the web dashboard? (open your web browser and point it at the IP address of the MCM)

* If you directly connect the MCM to the ethernet port of your machine via the supplied ethernet cable, can Smartware/Quickview see the MCM then?

Hello DarrenHill

Thank you for your responce.

In a nutshell the answers in the same order are

1  Yes

2  Yes

3  NO


I have not downloaded Quick View seperately because it seems to come with Smartware.

When I try and open Quickview it starts off as it was doing something and then nothing, it just stops.

I did have Smartware & Quick view on my computer (be3cause I had a WD passport) before I installed the MCM but as it didn’t show the MCM either, I uninstalled and reloaded it leaving the Passport unconnected.

I intended the MCM to take over from the Passport.

I am just adding this as I want to give as much info as possible.


But QV/Smartware can see the MyPassport OK?

All I can think of is a firewall issue or something like that blocking the view over the network to the MCM. But both programmes should happily see and support both MyPassport and MCM (I also have both at home, and both show up when both are connected to the machine).

If you’ve removed and reinstalled with the latest versions of the software, then I’m not sure what the next step would be. I did have issues at the start with my MCM being poorly recognised, which was due to an old router and so low network speed. But if it’s also not seen via a direct connection of the MCM to the computer via cable (to remove the network from the equation) then it must be something local on the machine itself, as I said possibly AV and/or firewall.

Other than that it may be one to escalate to WD support directly?

1 Like

Thank you for the speedy reply. As I am retired, I’m glued to the screen.

What makes the backup situation more important is that I had a head injury many years ago and have no memory so my computer is my memory. Without that I be lost. Hence the importance to me of backup.

I think the passport was showing because it was attached via USB (but then again direct connection to the MCM should have worked).

It seems everything else with the MCM is working fine.

I copy and pasted 64 Gb of photos yesterday from my machine to the MCM and it only took 56 mins at a top transfer rate of 26.8 mps.

I have four users at present and I/they can connect effortlessly with our mobiles.

I have tried it without the Firewall and still no joy.

I have gone into the router and the MCM is shown in the connections but it appears to give me little choice to change any other settings.



I have also gone into my control panel/Windows firewal and given WD My Cloud, Smartware and Quickview accesss to allow them through Windows Firewall.


Something really strange just happened.

It didn’t work before but I thought I’d try again.

I unplugged it and plugged it back in.

Suddenly it appeared in Smartware!!!

I went to make a coffee and when I came back it had gone again.

I don’t want to unplug it again as the lights are flashing,

I will try when they stop and report back.

I have also put a support ticket in.


‘Leave me in the dark and I will find the light’.

I have tried to replicate the event 3 times on unplugging/plug in but to sign of the MCM in Smartware.

I have put the Passport back on via USB and it came up in Smartware straight away.

Are there any things in settings on the dashboard that I should change such as LLTD?


‘Leave me in the dark and I will find the light’

I am still perservering with trying to sort my own problems but continually hit a brick wall…

To add to what I have already mentioned, I am using a TP - Link, 5-port gigabite desktop swithch inbetween the Virgin Media superhub and the MCM among other hardware.

I am also using a Cat 6 cable from the Switch to the MCM.

I thought that might be the problem so I tried a couple of things.

1/.  I connected the MCM with the Cat 6 direct to the router.

2/.  I took off the Cat 6 cable and replaced it with the Cat 5 cable that came in the box and connected it to the Switch.

3/. I connected the MCM direct to the router with the Cat 5 cable

With all 3 attempts the MCM still failed to show up in Smartware!!!


‘Put me in the dark and I will find the light’     (it’s getting hard at the moment.

That was why I suggested to try connecting the MCM directly to your computers ethernet port via the ethernet cable - it will eliminate the network completely (or will make the network consist of just the cable if you prefer). If Smartware still can’t see the MCM in that configuration then it’s either something wrong with the computer, the cable or the MCM itself.

But as the MCM is visible by other methods (SMB and HTTP) that would tend to rule out the cable I would say, and there should be nothing on the MCM to configure to make it talk to Smartware (if the MCM firmware is the issue somehow then it’s one that only WD would be able to identify and resolve).

Do you have another computer that you could test it with? Other than that I’m not sure there’s much more to test beyond what WD tech support might be able to suggest on a more technical level.

Hello DarrenHill,

Thank you again for your input, I really appreciate your time and trouble.

Further back in the post I mentioned that I got it to show in Smartware after pulling the plug on the MCM.

Unfortunately it came and went and I was unable to replicate its arrival again.

I just have this gut feeling that there is a setting that needs altering either on the MCM or the computer.

It’s a shame (a big one) because everything else works fine.


‘Leave me in the dark and I will find the light’.

To the best of my knowledge there isn’t any settings on the MCM that Smartware needs, at least for visibility (actually backing up needs the backup share, but that’s nothing to do with the initial visibility of course).

All I can suggest is to try a reset of the MCM firmware, or perhaps to try and simplify your computer set-up (safe mode with network support, or minimising running programs etc that could be blocking the communication or getting in the way.

But beyond that I’m out of ideas to try and help, it needs more deep techinical knowledge that WD tech support should be able to provide (I hope) if you can raise a ticket and get one of them to assist you directly.

Best of luck!

Hi Darren

I mentioned in an earlier post that I have raised a ticket.

Whilst I have a limited knowledge about computers, I am loath to meddle unless under instruction so to speak.

I think the MCM is a great bit of kit and I will not give up on it although I might break something or kill someone along the way…lol


Dear all,

Could this be part of my problem?

I uninstalled smatware and quick view several times using the windows uninstaller but I am almost sure it sent it to the WD uninstaller.

Yes, I am clutching at any straw I can but I won’t give up.


Uninstalling on Windows 7 or Vista

  1. Click Start > Control Panel.
  2. Double-click Programs and Features.
  3. Click WD SmartWare Installer or the WD SmartWare Installer icon and click Uninstall/Change at the top of the screen.

IMPORTANT: DO NOT select WD SmartWare on the Windows Programs and Features dialog. You must use the WD SmartWare installer/setup wizard to uninstall the software if you used to install the software.

  1. Click Uninstall on the WD SmartWare installer/setup wizard and wait for the uninstallation to complete.
  2. When the uninstallation completes, click Finish to close the WD SmartWare installer/setup wizard…

Sorry all, this is a blank message because I do not know how to delete it!!

I really hope I’m not being a pain with all the messages I post but I REALLY want to solve this issue and want to be seen to be doing something.

Does Quick view play a part in discovering my MCM?

I say this because I think my Quick View is faulty.

I click on the icon and in my Windows 7 the circle starts spinning like it is doing something and then it disappears and nothing happens.

Everytime I try and re-download it I get the message ‘there is a newer version on your system’.

But it doesn’t do anything?

I also found a WD web page that mentioned the ‘Discovery tool’



This download contains the latest version of the WD Discovery Tool. The Discovery Tool is used to locate WD drives on the network, and to create mapped network drives from their share folders.

Has anyone used it or got any thoughts on the matter?


Any thoughts or observations on any of the ideeas I have put forward will be gratefully received.


‘Leave me in the dark and I will find the light’.

Just a quick update on anyone following this thread.

I was contacted by Support via email with the following:

run, services.msc

Look at the following services, if not already started then double click the service and opt to start and ensure startup type is set to automatic.

  • Link_player Topology Discovery Mapper
  • DNS client
  • Function Discovery Resource Publication
  • SSDP Discovery
  • UPnP Device Host

I went in and made alterations as per the request.

It didn’t work for me although it might for you. I still could not see MCM in smartware.

That was the only message I got today by (16.45 GMT) and I answered pretty soon after getting it. I received NO further communication from support.

_ This is going to be a long process if they only send me 1 message per day!!! _


‘Leave me in the dark and I will find the light’.

I have just sent this to Andy in Technical.

Hi Andy,

I hope you received my previous 2 replies to your initial mail and this is the third with some new information that might assist you in my quest to get things working.


I don’t know if this is a coincidence but today I fitted a Virgin Media Superhub 2 version V1.01.09, hardware 1.0.3.

I looked in my taskbar and in additional progs not actually shown on the taskbar was the Quick View icon.

I hovered over it and it was showing ‘My Passport Ultra’.

I clicked on it and got:

  • Safely remove my Passport
  • And WD MyCloudMirror with an arrow with two choices being ‘wake up device’ and ‘Forget device’. 

It still wasn’t showing in Smartware.

I clicked on Wake Up Device but it still failed to show up in Smartware.


So it is recognised by Quick View but the information is not getting through to Smartware?


I also went into the router settings and the MCM is shown as a wired setting together with the MAC address.


So the signal is going from the MCM to the router and then to the computer where it is recognised by Quick View but NOT Smartware!!!


I hope this bit of info gives you more of a view on the problem I have.


I await your reply


Pete (Papadadio on the WD forum)

Pete, what you describe as now visible in Quickview is exactly what I used to have using my old router (the slow one that stopped access to my MCM via Quickview, not sure if it also affected Smartware or not).

But if a direct link of the MCM to your computers ethernet port via cable without anything else did not make the MCM appear (it fixed it on mine, which was how I localised it to the router) then as a next step I’d confirm the speed of your ethernet port on your computer and maybe check the drivers for it.

1 Like