Smartware system tray disappeared and auto sign in not working

Subject line says it all really.

When my computer wakes from sleep I have to put in my password for Smartware to start despite the Enable auto sign in box being ticked.

Also the system tray icon has disappeared.

All slightly odd - any suggestions?

Running 2.1.0

Well…I seem to have found the system tray icon again by starting Quick View from Programs>Western Digital>WD Smartware folder - but not sure why it disappeared in the first place.

Remains to be seen what happens with the recovery from sleep situation though.

Problem continues. Tried undoing “Enable auto…” via WD Security and then wanted to reinstate it but now that option is greyed out and I cannot re-enable it. Have raised a support ticket - will update when I know anything.

My issue was escalated to support (thanks Hamlet) and they responded. Solution was to disconnect MyPassport, uninstall WD Security, download latest version of WD Security from the download page and reinstall. Solved the problem. Enable auto now works. Thanks to support for quick help.


Im very glad to know that your issue has been resolved.

Thanks you for sharing the solution, hope this helps other users.