Smartware issue on Windows 2008 R2

I’m out of ideas to solve the problem of imposibility to access the drive under windows server 2008 r2 foundation.

The following message is in Polish, but it relates to the issue, that when I click on the padlock, an error message displays :
Authentication failed
(details) Could not find the file specified (Exception from HRESULT 0x80070002)

Until now I’ve done:

  • Enabling upnp on the router, which the drive is plugged

  • Disabling the firewall

  • Installation of the latest firmware for the drive

  • Installation of the latest SmartWare software (as an administrator)

  • Disabling UAC

  • Assign a fixed IP address for drive in LAN

  • Checking if all WD services run automatically at startup

  • Setting public access to the drive on the LAN (all users can access without a password)

What is interesting in the WD Quick View I can see all the information about the drive.
On other computers with Windows 7 and XP, the problem doesn’t occur.

Do you have any suggestions to solve the problem?

If indeed SmartWare software doesn’t work on this Windows (after applying various workarounds), please suggest me another ways to fully automated data backup?

Hi, unfortunately Smartware is not supported under Windows 2008 R2, you should be able to use Windows backup and restore to backup your files. Click on the following link for more information. 

Description of the Windows NT Backup Restore Utility for Windows 7 and for Windows Server 2008 R2

http://support.microsoft.com/kb/974674/en-us

Is WD Smartware supported under MS Windows Server 2008 Enterprise With SP2