Smartware ERROR - application not started from drive

Dear all,

I have a problem with Smartware install, Please do a favor to help me to solve. Many thanks.

I bought a My Passport Essential 1TB, when I tested it, the smartware can run and installe, then I cancel it.

When I arrtived home, formated the disk, and use it as normal.

Today I want to try SMartware, I follow the KB5419 ( WD SES driver download and instructions for recovering the WD SmartWare installer ), download the WDSmartWare_PP4R2_1_4_1_2, extract the file to disk.

When I try to run the smartware, it shows an error: application not started from drive

Then I tried servel ways to solve it, such as clean disk using diskpart, format it using WD QuickFormat, but all failed, same error.

I tried search the Community and try to install different version SES driver, both failed.

I tried install smartware msi package and I found My Passport is considered to be a local hard disk.

Could you please tell me how can I run smartware on my WD My Passport? Or how can I totally reset my disk.

Great Thanks!

update the firmware on the drive…

once updated extract the Cd image and copy to drive

launch the installer…

make sure to uninstall any previous installer package

Hi Wizer, thanks for you reply.

I tried before, but still failed, maybe some steps is wrong.

  1. using diskpart, clean all disk

  2. run firmware update, it is already up to date, update again.

  3. create a new partition, copy image to it

  4. still failed

any good idea?

In case you haven’t sorted it out yet, I had the same problems, all i did was put the smartware files onto the drive and run smartware updater even though smartware was not installed. It’s back to normal for me now :slight_smile:

“All I did was put the …”

Sorry but what does it mean: " onto the drive? Which drive?


Roberto from Italy

When you do the firmware update make sure your Adobe Flash and netframework 3.5 often called .net are up to date.


Hi, I have the same problem with my passport  500 G. I made the same thingsyou did but  the programm doesn’t  work yet and the same **bleep** sentence appears.

How did you solve the problem if you had solved the problem.

Roberto from Milan