SmartWare Doesn't hook up with My Cloud - NEW Headscratcher

Ok, here’s my headscratcher – I have a 2TB MyBook Live that I use as a file server/storage space, and a 3TB MyCloud that I use for backing up a couple of Win Laptops/PCs and the MyBook. All was well until I bought another PC. I installed SmartWare on the new box, and while it can find the MyBook live file server, it just can’t seem to connect to the MyCloud backerupper. I can see/access the MyCloud in File Explorer, can connect to its web interface, but Smartware ain’t being so smart in this case.
OK, so one more piece of headscratcherness. I CAN see the MyCloud using SmartWare from another computer on the same network in the same Workgroup.
Stumper? Help?

Never mind. I tried to do the “Update” thing from the app, but found out the virus ate the server. So I did 3 of the 4 “R’s” thing - Restart, Reboot, Reinstall, and Reformat. Luckily I didn’t get to the 4th. I d/l’d the latest and greatest version of Smartware, and Poof!! It worked!! Bizarre, but who am I to question the ways of software?