SmartWare does not see my MyBook Essentials 1TB drive

Hi all. Lately, when I plug-in my MyBook Essentials drive to the USB port of my PC, the popup window for unlocking the drive appears and I put in the correct password. After that, the SmartWare icon on the taskbar says “Drive discovering.” After that, it shows my drive (says it’s G:\ ) is 0% used. However, I have backed-up data in it before, so I know there is data in it. I launch SmartWare. This time, SmartWare does not see my MyBook Essentials. Instead, it only sees my computer’s hard drive, and the Backup and Restore tabs are dead / faded / do not work. Yet, when I go to My Computer, I see the MyBook as two drives (F:\ and G:). F:\ I can see the SmartWare items. In G:, however, when I click on it, the window freezes and nothing appears. I have rebooted my computer several times. Nothing worked. What is my problem? The data in my MyBook is precious and I want to get it out. Thank you in advance.

Hi there

Here some recommendations:

1- Uninstall WD Smartware and restart the computer.

2- Make sure you have Adobe Flash Player and Microsoft .Net Framework.

3- Install WD Smartware or update the firmware and software if needed.

1 Like

The only thing to add is make sure your Flash and Net Framework are up to date.


1 Like

Ok, I will try your solutions soon. I’ll let you guys know if it’s a success. I’m quite busy for the coming days and so I might not be able to respond immediately to all your solutions. Please be patient with me, thank you. Question: since I will reinstall SmartWare, and at the installation screen it asks for a password, do I provide the same password I used before to lock my drive? Also, will the reinstallation of SmartWare affect my backups in the hard drive (which I cannot access, even via My Computer)? Thank you.

Ok. So I did what you guys told me. I uninstalled SmartWare, installed the latest flash player and NET framework. I even used another USB cable. I rebooted, plugged in the drive. Canceled the wizard, clicked on the virtual CD partition of the drive, installed SmartWare. The installation process then ends abruptly, telling me that “No writable WD SmartWare partition found.” Now I cannot even see the hard drive in My Computer (except for the virtual CD which is F:\ on my computer; the other partition when it was working was G:\ ). Is my drive dead? Is there no way to retrieve the data in it? That’s years of data. I am very sad. :frowning:

What OS do you have? if WD Smartware is not working properly but the external drive is recognized on the computer you can use Windows Backup if you have Windows Vista or Windows 7.-

1 Like

WinXP service pack 3. The computer can no longer see the external drive, only the virtual CD partition. There is no more additional drive listed in My Computer. To be sure, I just installed the drive on another computer. Same result: Nothing. I have “No writable SmartWare partition found” message. I did a Google search for that error message and some of the results point to this site. I checked it out and it seems many here have that same error message and did not find a solution. Is my hard drive dead? :frowning:

If the computer can no longer see the external drive, I would recommend to access Disk Management to verify if the drive needs to be formatted

to access Disk Management click on Start > right click on My Computer and click on Manage.

On computer management you will see Disk Management (the second option from bottom to top on the left)

On Disk Management you will see all the information about all of the drives you have on the computer, make sure your external drive shows healthy, if is showing unalocated then you need to format it.

If the external drive doesnt appear on Disk Management, then try another USB cable or try the drive on another computer, if the drive doesnt show on another computer then the drive is defective and the only thing you can do is to contact WD , verify the warranty and get a replacement.-

1 Like