SmartWare backup don't stop


I have some problems with my WD Smartware software. Sometimes WD Backup Engine start working and don’t stops the backup process. The signal comes from my CPU (WD Backup Engine high % consumed) The last time happened when I make the update of SmartWare software.
I restart the computer and the problem continues. Open SmartWare and the backup process always active.
Sometimes I can stop it deactivating the backup and reinstall SW. But this can’t be the solution!
It’s a SW bug? Any solution?
My OS is Windows 8.1.


Have you opened up SmartWare and looked under the Help tab? At the bottom of the page you will find a link to the Online User Manuals.

Update: I just updated my desktop and laptop to SmartWare version 2.4.2. See image below.

Posted by,
cat0w (USA)

and…??? what’s the point?

maybe i didn’t explain well: SmartWare starts the “backup process” to the disk and don’t stops; CPU’s high consumer; fans noise; etc

something happens with the software and the “backup process” freezes…  even after restart the computer!

for now, the only solution i found was uninstall and reinstall SW.

After that, everything is ok… for some time, until the problem reappear from nothing. Today, the problem appeared after the update installation…

so, maybe exist any problem with the software or incompatibility with other software or OS.

PS: maybe I’ve explained the problem with ‘bad’ english, but i’m not a ‘stupid’ neither ‘myopic’

Thanks WD for your help! You are great! Software remains the same…!!!


I ran into this problem as well on a Windows 7 x64 machine. The Smartware software just seemed to continuously run the backup process. It even was preventing my system from going to sleep. And restarting the computer didn’t help either. the only way to get my CPU back down to a normal level was to open the Smartware interface, and choose to disable backup. Not much of a solution!

What I ended up doing to solve it was to delete the Smartware volume information stored on my system drive. After that, when I brought up the Smartware interface, it reported that it was indexing my system drive. Then I believe it went into the backup process as though for the first time (probably because I’m set for continuous backup still). In the end this worked out well for me. It had the Smartware software functioning normally again. And what’s more, all the original files remained in the backup. In other words it seemed to more or less just verified everything again rather than doing an actual new backup. Even previous versions of files I had long deleted were still available to me for retrieval.

The only other way I think this could have been resolved would have been to actually choose to erase the drive, and then start a new backup. That wouldn’t have worked out for me. Not so much because I would have lost a lot of archived files. But I also keep my system image stored separately on my external drive (A 2TB My Book Essentials btw.). Not only that, but I think the repair process went a lot faster than if it were to have been actually backing up all my files. Like I said, it seemed to be verifying files rather than backing them up.

Now as for what caused this to happen in the first place… I don’t know. I tried to duplicate it, but couldn’t. I thought it was because I was manually going into the swstor folder stored on the external hard drive and deleting old files I didn’t want stored there anymore. And for anybody interested in that- those files will no longer show up for retrieval which is pretty nice. Anyway, I tested that out and it didn’t seem to cause any problems. I tried duplicating a lot of the things that I though might have caused it, such as disabling backup in order to move large files around. But I couldn’t get it to happen again. Although there was a very long backup process after re-enabling backup when I had moved some large files in and out at one point. I don’t know why when you consider that the software was disabled through the whole process and I had completely deleted those files before re-enabling backup. It’s like Smartware knew the files were once on the system drive.

I had been testing the **bleep** out of the Smartware software because I had just bought this drive and was debating whether or not to just letting windows take care of backing up my stuff. I came real close when I realized that I had an option to retrieve previous files in Windows 7 pro. But then I saw that they were only retained during system restore points or backup periods. Where-as Smartware was almost instantaneous. I really debated this whole thing because I was seeing a lot of bad reviews about the software. So much so, that I almost never even bother to install it. But I was so impressed with it, that I even considered blogging something about it. Then of course this happened. Hopefully they can get whatever bug caused it fixed. The only real complaint I’d have about Smartware other than what happened to me, is there should be an option to automatically list the files that are no longer on my system and give me an option to delete them from the backup. I think the Anywhere Backup version had a purge deleted files ability. Something like that would be nice.

Anyway, what I did to correct my problem in more detail was to choose disable backup in Smartware. Then I had to locate the folder on my system drive that contained the Smartware volume information. On my PC, that was located in a folder called ‘Program Data’ that’s in the root of my C drive. It’s a hidden folder, so you’d have to set your folder options to show them first. Inside that folder there is a folder called ‘Western Digital’. Inside that is one called ‘WDBackup’. The only  files I deleted were the ones that began with Volume. There were four at the time. (I’ll include a screenshot). Now the only problem was that the system wouldn’t let me delete those files because they were in use by Smartware. So I had to pull up the program’s processes to kill them before hand. So using CTRL+ALT+DEL I started the task manager and looked for the processes to kill so that I could delete the files. (I’ll include another screenshot). Keep in mind you’ll want to delete the files quick because the processes will start right back up again. You could try and just kill the WDBackupEngine process- Although I think I had to kill the other WD processes running as well. And I might even have needed to have gone into the services tab and killed them there instead by right clicking on them and choosing stop service. Sorry I don’t remember right now. But one way or the other, you have to stop the Smartware software from running to delete those files. After this, I was good to go. I launched Smatrware again and re-enabled backup. That was it. Just waited for the files to sync up. One thing I might mention to people that have more than one drive or system  backed up somehow- and I don’t know if it’s the case or not because I don’t. Is that if you see completely different volume names in the backup folder, that you might want to check swstor folder that is stored on your backup drive to make sure of the right volume name before deleting. Just thought I’d throw that in there :wink:

The reason I went to all the trouble of writing this is because I really think the Smartware software is decent. And I think a lot of the bad reviews I’m seeing about it are having to do with people’s systems getting bogged down. This might just be what’s happening to them. Either way, it happened to me, and this is how I fixed it. Good luck!


Okay. I just had this problem again (Not even 24 hours after posting this :cry:). So I thought I’d edit this post to simplify things a little.

For all the ways I tried earlier, I couldn’t get the software to act up again. But wouldn’t you know I had it happen today without trying. I accidentally powered off my computers power-strip today while my computer was running. When it restarted, I was having the problem again. It might be worth noting to any WD techs that might be reading this that when the problem first appeared the other day, it was after a restart.

Anyway I just wanted to mention that I stated earlier that I wasn’t sure what WD processes or services needed to be stopped in order to delete the volumes in the folder I mentioned. It turns out that the only process that needs to be ended is the WDBackupEngine (You can see it highlighted in the screenshot.). You’ll have to choose to show processes from all users to see that first (at least in my case). And like I said, be quick about deleting the file(s) because it will start right back up again. Keep in mind that I had disabled backup in Smartware first. Now the reason I say file(s) is because I also found that the only volume file that needed deleted to set things right again was the larger file ending with a .db3 extention only. There is another ending in .cj.db3- but I found it didn’t matter if I deleted that one or not. You can delete both for good measure if you like.

On the technical side- I think the problem lies somehow with the windows shadowing service. I think this because like I mentioned above, there was a lot of activity when I re-enabled Smartware backup. I wouldn’t have expected it to have acted that way after I had moved some large files in and out because Smartware disabled.

That’s it. Hope it helps someone out!


I’m trying very hard to stick with this software because I really like the way that it keeps a record of things automatically. But I’ve had this issue come up far more often than I’ve liked to this point. Anyway, I’ve been trying to track down what is causing it, and so far other than something to do with Windows shadow copy service, it appears that it might have something to do with my mail programs. Windows Live mail in particular. I say this because when I’ve watched the progress of the backup process in Smartware’s backup screen during one of the hang times, I noticed that there is a very slight change happening over and over again with the mail status graph. And I think I saw something in the logs mentioning that program. So rather than uninstall Live mail. I decided to just deselect that category for backup. So far so good. I’ll update something later if it doesn’t turn out that way. And as much as backing up my mail really isn’t that important to me, it would be nice to find a solution to this somehow. No version updates from WD to speak of at this point.

WD Process.png