Smartware 1.6.2

While installing Smartware 1.6.2 for my 2TB Book Live, I got a message: “Failure to load Resource DLL”, but it didn’t specify which DLL.  I clicked OK (only option I had) and Smartware appeared to install OK, or so I thought.  It started fine, so I started a backup of all Music and Pictures (18,000 files).  Appeared to be running fine, so I want to bed.

In the morning, I saw that the software had crashed.  I had multiple windows open - when I moved one to read it better, I immediately got the BSOD.  I rebooted and started Smartware again.  It showed that it had attempted 18,000 files, but had a yellow warning icon that said approx 9.000 files HAD NOT been loaded.  When I clicked, a popup appeared with a scroll bar - yep, scroll through 9,000 file names it could not add.  OK, so I popped up Windows Explorer and noted that the Book Live had no files on it (0 Bytes), aside from the system software.  I’m assuming that was due to the fact that Smartware abended in the early morning and didn’t finish up.

So I tried uninstalling and reinstalling Smartware from the CD - same DLL error message.  Uninstalled and reinstalled with 1.6.2 from the WD site - same error message.  Physically the drive looks fine, with all LEDs showing proper status, but now I’m afraid to run the Smartware backup again.  I thought I’d copy a few files to the drive, just to see, and I’m sure that will be OK…but unattended backup is why I bought this thing in the first place.

Any ideas???  Incidentally, I’m using Windows 7 - nothing exotic running with it. aside from Weatherbug, and I even shut that down to see if it was a weird resident software glitch.

Well, I am beginning to understand this software a bit more - the manual doesn’t explain a lot.  I notice that if you use the drive as an ordinary drive (drag & drop), you can see your files.  If you let Smartware perform backup, the backup is logged but you cannot directly view the data unless you retrieve it.  I sucessfully backed up my Mail (very little) and retrieved it.

So that works, but Smartware did crash last night and failed to back up 9,000 files.  I wonder if it exceeded a log threshhold or something like that and crashed…?

I shall try backing up my music and pictures in small increments and see how that works.  That DLL thing continues to be a mystery.  Googled it and didn’t find much of value.


I have never seen such poor software since I got my first computer in 1983. It is abominable, and unacceptable. It is so poor I won’t waste keystrokes describing the problems. Someone help us with third party backup softwware please! I do not want to use DOS .bat scripts for my backups on my Windows machines.

Yeah, it’s a bit clunky.  Having spent a long career in I/T, mainframe to all this…I’ve seen it all.  I guess if I had some clue as far as how the software works, I’d have a better idea.  For instance - stopping and starting backups.  Does it happen automatically or must you apply the changes individually?  Deleting backups?  I’ve tried to stop backups to Mail with no success.  When you get the list of warnings about files not backed up…how can you clear the list?  It goes on and on.

Now, I don’t have any answers and I cannot say that unattended backup is easy, but this software isn’t cutting the mustard.  I’m giving it another try with my pictures and, so far so good - should be completed in a few hours, so we’ll see.

pj (Paul)

Ok, SmartWare backed up my pictures with no errors, so I shall attempt the massive Music arichival before I hit the sack.  I’m crossing my fingers but…it’s working.


Just did backup of “Documents”.  SmartWare tends to hang if it can’t get exclusive access, so while it hangs, start shutting everything down in your System Tray that it is safe to do and you’ll fine that SmartWare wakes  up and continues backing up.

So far, I’m getting happier.  The software works - it’s the documentation that’s the problem, folks!  I’m getting this beast to work just fine. but it’s taking some doing.  It’s obvious WD needs technical writers who know the software/hardware very well, and it’s obvious they don’t.  I’m not interested in employment - happily retired!


No way.  Resident software gets in the way - got BSOD again in the middle of backup.  Hog on system resources.  WD has to do better than this.  Hardware is fine, software isn’t.  Cannot trust anything the software does - use like a plain old external drive and that’s about it.  Wasn’t why I purchased this unit.  Not happy with WD.


Hi, are you usually doing anything specific when you get the BSOD or does it happen randomly? Did you also tried to download the latest firmware update for the my book?

Was not doing anything aside from watching the BSOD occur.  Only resident software in the system was McAfee.  I shut down Skype, etc etc before I attempted backup.  The firmware is up-to-date.  I’ll fire up SmartWare later on today and see if the backup of my music files will resume.  You never know.

Funny thing is that, after the initial backup, it seems to be OK insofar as incremental updating goes (when a file is added or changed).  I also thought of doing this in half-hour sessions, since it seems that SmartWare doesn’t do well with prolonged backups (my assumption).  So…I have everything except my music backed up by category, with the music partially backed up.  My problem now, is that I’m understandably reluctant to trust the software to be it’s job correctly unattended.  I guess it would be easier if SmartWare behaved consistantly (you do this and something happens), but it’s capricious.

The software really doesn’t let you see much of whats’s happening behind-the-scene.

I appreciate you jumping in to add your thoughts.


Well, I restarted backups and it’s just sitting there.  No progress that I could see, but noticec that WD pushed out a firmware update TODAY.  I shall apply that and try again.  Will report back.


Ok, I applied the new Firmware Update to completion and rebooted my laptop after the drive rebooted and re-initialized.  Started Smartware up and restarted the backup - just hangs with no indication of progress.  4,200 of 12,000 audio files not backed up.  Over 4,000 in the rejects - reason if “Invalid file location”.  Well, I can play 'em in iTunes!!!

Oh, well…  This dog don’t hunt.  I guess I am going to have to use this drive as a drive to drag and drop as I need and handle backup myself.  Rather disappointed, I must say.


Just in case you can also use Windows Backup. Check the link below for the steps.

Thanks for that, as that may be an option I can use.  I’ll give it a try.  Do you know if, aside from a doing a “Factory Reset”, there’s a way to delete individual backups?  I knw there’s the little trashcan thing, but I’m not certain that is the list only or the contents which were added to the Cloud Storage.

Lousy Documentation.  I added a case and have heard nothing from WD.  I expect I won’t.


Yes, you can delete the backups from the dashboard, you can read more about it on the manual, check the link below.

Ok, got it.  I was not sure about that, so when you click the trashcan, it DOES delete the actual data from the cloud.  I had suspected that, but needed verification.

I really appreciate your assistance.  I have to ask:  Are you having problems with this software, or am I a unique case?  Driving me nuts.  I’m an old fart I/T guy and it makes me crazy when I cannot figure something out, but this has me stumped.  On the other hand, I can recall the days when 2TB of storage would occupy the space of a few huge warehouses full of disk drives.  Amazing times!


I prefer to copy my files manually. :wink:

I am cautiously declaring victory - this thing seems to be working now!  WD contacted me after I opened up a case, so I called them back.  Spent about an hour or more with a very patient, pleasant and knowledgeable fellow who really wanted to get this thing resolved, and he got results.  Seemed to be a mixture of issues:  I don’t want to get into WHAT he did, mainly because every system tends to be different, but the end result appears to be good.  Nothing is hanging and while we were waiting for my several restarts, I had the opportunity to ask him some questions about how SmartWare works, and he was happy to share what he knows - I learned a lot…  ANY company would be happy to have a guy like this on staff.

I worked in the I/T business for 40 years and, believe me, it’s true that there ain’t no software ever written that is perfect…well, perhaps ONE program - IEFBR14, if any of you Old Farts remember that from your Assembly Language days.  Not many of us left - the pioneers of Data Processing!  After software is produced, Quality Control departments only do what’s in their script - It is not really tested until it reaches its intended market.  And that is what product support is all about.  For me, WD has done OK., and I’m a hard person from whom to get compliments but their effort has been commendable.


Well, the entire backup completed.  All pending files have been backed up,  New stuff being added.

Took a bit of doing, but, at this point…this is is OK.


Well, WD tried and it looked OK but…no.  I booted up my laptop yesterday after everything was backed up.  I popped up SmartWare, and it was decrementing the files backed up until it was zero!!!  No, I didn’t inadvertantly delere anything.  SmartWare will not begin backing up again and shows nothing, even when I enable shares to the Public area - so the drive IS b lank.  This is nuts.

The hardware is OK, but I just cannot trust this software.  It was working until MS pushed a Framework update then it all went bad again.  How can you trust this to maintain a backup when it is this brittle?

Looks like factory restore and drag 'n drop, or I’ll try Windows 7 backup and see what that does.


Well, things change quickly - after watching the decrementing to zero, it quickly went the other way and everything seemed backed up on both laptops, confirmed by doing shares and viewing the content.  A week now and all’s well - everything is being backed up incrementally as things change.

One point - the documentation for 1.6.2 says that you can adjust a time to update when the computer is inactive.  It isn’t an option in 1.6.2 that I can see in “Settings”.  All the same, not a problem.

We went away for three days and took our laptops with us.  Took lots and lots of pictures and transferred the SD Cards to Picasa on our respective laptops (new grandchild).  When we got home and connected to our home cloud, both our laptops were essentially useless for about half an hour while the backup drive caught up.  After that, everything was fine and keeping up with backing up files as we create/change them with no discernable degradation.

I can live with this, and I am a happy this thing works.  An observation is that the resident software appears to work just fine, but the software you see (Smartware) does not keep pace with the hardware - or takes a long time to catch up.  There seems to be a disconnect between with what the drive is doing vs what Smartware is reporting it is doing.