Smartware 1.3.0.16 startup issue... WDFME.exe?


#1

All, i have a ‘my passport essential’ 320mb drive and recently installed both firmware and smartware updaters, exactly per WD procedures, and all hell broke loose… it’s version 1.3.0.16 (updater file says …0.16a).  The laptop is a Toshiba m600 running vista business, fairly standard corporate specs with Outlook, Office, CA eTrust, IE, adobe, winzip, java, .net installed; bluetooth, wireless stuff turned off.

Before the updates, smartware worked albeit very slowly.  Now, it’s not and at best inconsistent but most of the time, it’d hang upon starting… i traced it to a process called WDFME.exe; it also takes up a lot of CPU (80%+ sometimes), if it starts… basically, the smartware windows kind of going on/off… one minute it looks normal (though i still cannot ‘get hold of it’), seconds later, it blanks out and is ‘(Not Responding)’… and this cycles non-stop and i had to close the application every time in the end.  WDFME.exe registered 10% to 80% cpu while this happened… with screen blanked out when cpu% went high, and screen reappeared when it went low…  this part is predictable.

However, WDFME.exe may not start in which case all i see is a smartware home page without ‘categories’ (blue boxes) for my laptop drive (presumably WDFME’s job is to categorise files). i do not know why WDFME did not start… it’s pretty much the same after a proper laptop reboot or shutdown, with or without the my passport drive attaching to it, i.e. random far as i can tell.

WD L1 talked me through uninstalling/ reinstalling smartware, as well as reformatting the my passport drive; backup worked once after this however went back into the same problems.  The ticket is with WD L2 support however it’s not doing anything, except asking me to unstall / reinstall a bunch of aforementioned standard software, without any troubleshooting??  i am honestly quite dumbfounded… 

It’s a corporate laptop… all software is licensed and up-to-date with auto update running; again, no prorpietary stuff.  With help from our IT folks, i ran an update check utility and verified all installed apps are indeed current.

any ideas?  appreciate your help…


#2

I’m having a similar issue and have been working with both L1 & L2 support.  My issue is that I get a popup error message “WDFME.exe - Application Error, The exception unknown software exception (0xc0000409) occurred in the application at location 0x7a0ca6be.”  I found that I can restart the wdfme.exe service from the Admin Tools in Windows without having to reboot my PC, which will work for a day or so before the popup error shows up again.

Support has had me run the Complete Drive Test, uninstall/reinstall the WD Smartware software, upgrade to the latest firmware, defrag all my drives, and run chkdsk on all the drives, but still I keep getting the error popup.  I hope that WD can fix these problems soon. 

Is there any 3rd party software that can do the same thing as Smartware that maybe I can just use the WD drive and not this problematic Smartware software?


#3

If you have Windows XP, Vista, or 7, you can use Windows Backup utility.