Smaller Partition Suddenly Mounts w/o PW & Contents Gone

I looked and looked but did not find THIS problem addressed. If it was, I apologize.

4TB My Passport for Mac, Partitioned:

  • 1st Partition - 3TB, PW protected
  • 2nd Partition - 1TB, PW protected (different PW)

Drive has worked flawlessly since MAY of 2018, attached only to my MacBook Pro. Couple days ago, inserted the USB cable, was prompted for the 3TB partition’s PW (as always). Except this time BOTH partitions mounted when I entered the first partition’s PW. Furthermore, I see NO files on the smaller partition!

Neither partition was even close to capacity; no recent OS changes; nothing unusual that I can recall - it’s just that the system suddenly stopped asking for the second partition’s PW but just mounted it with the first. It WOULD APPEAR the PW and all content were wiped from the 1TB partition. But… how? I tried saving a small file to the 1TB partition and it did save so… looks like I’ve lost everything on that partition. Thoughts?

Thanks!

Hi @RetiredATC,

Please test health of your drive using Western Digital Drive utility:
Link: Setting up and using WD Security and WD Drive Utilities

Thank you for the suggestion. But after digging deeply through this community and consulting multiple additional sources, I found no viable solution.

The partition has been reformatted and re-encrypted, and three years’ worth of irreplaceable and un-backed-up creative work is gone.

Hi @RetiredATC,

Please refer below link to help you with trouble shooting steps:
https://support-en.wd.com/app/utils/login_form